summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-11-04 01:05:12 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-11-04 01:05:12 +0000
commitdab5ebaa76d6432459ba6e26ab22600ed85dd3e4 (patch)
treee00a2fa277296d2299cfff100c251c0e52a7f62f /package
parent18a4bbb98d339eb8aac1b1b0e5b6fa6d9339f9ad (diff)
downloadmaster-31e0f0ae-dab5ebaa76d6432459ba6e26ab22600ed85dd3e4.tar.gz
master-31e0f0ae-dab5ebaa76d6432459ba6e26ab22600ed85dd3e4.tar.bz2
master-31e0f0ae-dab5ebaa76d6432459ba6e26ab22600ed85dd3e4.zip
netifd: ensure that a bridge gets created before hostapd needs it, hostapd must not attempt to create the bridge by itself
SVN-Revision: 28745
Diffstat (limited to 'package')
-rwxr-xr-xpackage/base-files-network/files/lib/network/config.sh4
-rwxr-xr-xpackage/base-files/files/sbin/wifi1
-rw-r--r--package/netifd/Makefile4
-rwxr-xr-xpackage/netifd/files/lib/network/config.sh7
4 files changed, 14 insertions, 2 deletions
diff --git a/package/base-files-network/files/lib/network/config.sh b/package/base-files-network/files/lib/network/config.sh
index 29d021af92..74810e47d0 100755
--- a/package/base-files-network/files/lib/network/config.sh
+++ b/package/base-files-network/files/lib/network/config.sh
@@ -145,6 +145,10 @@ sort_list() {
) | sort -u
}
+prepare_interface_bridge() {
+ return 0
+}
+
# Create the interface, if necessary.
# Return status 0 indicates that the setup_interface() call should continue
# Return status 1 means that everything is set up already.
diff --git a/package/base-files/files/sbin/wifi b/package/base-files/files/sbin/wifi
index e2dd0a32d5..2e66bfcbe8 100755
--- a/package/base-files/files/sbin/wifi
+++ b/package/base-files/files/sbin/wifi
@@ -40,6 +40,7 @@ bridge_interface() {(
config_get iftype "$cfg" type
[ "$iftype" = bridge ] && config_get "$cfg" ifname
+ prepare_interface_bridge "$cfg"
)}
prepare_key_wep() {
diff --git a/package/netifd/Makefile b/package/netifd/Makefile
index 465acd4122..98b4a4044f 100644
--- a/package/netifd/Makefile
+++ b/package/netifd/Makefile
@@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netifd
-PKG_VERSION:=2011-11-03
+PKG_VERSION:=2011-11-04
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/netifd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=5c0c0bb557b17c581d4f238c52b0b44ada34a608
+PKG_SOURCE_VERSION:=b6d7a8bc9822667cb851bec465c3ad7cd6714e90
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
# PKG_MIRROR_MD5SUM:=
# CMAKE_INSTALL:=1
diff --git a/package/netifd/files/lib/network/config.sh b/package/netifd/files/lib/network/config.sh
index 778c964e7b..4ce362eb19 100755
--- a/package/netifd/files/lib/network/config.sh
+++ b/package/netifd/files/lib/network/config.sh
@@ -40,6 +40,13 @@ scan_interfaces() {
config_foreach fixup_interface interface
}
+prepare_interface_bridge() {
+ local config="$1"
+
+ [ -n "$config" ] || return 0
+ ubus call network.interface."$config" prepare
+}
+
setup_interface() {
local iface="$1"
local config="$2"