summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-04-09 14:51:15 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-04-09 14:51:15 +0000
commitd63666203ccd6807da9ce60af60897fd7bce94ae (patch)
tree666a33122a83d0cfd2f5cd18b3463b9cd438ef41 /package
parenta4f6398eda015560d972b9778fb9e3132d471d1f (diff)
downloadmaster-31e0f0ae-d63666203ccd6807da9ce60af60897fd7bce94ae.tar.gz
master-31e0f0ae-d63666203ccd6807da9ce60af60897fd7bce94ae.tar.bz2
master-31e0f0ae-d63666203ccd6807da9ce60af60897fd7bce94ae.zip
dnsmasq: add more options for interface binding (#4900)
SVN-Revision: 15172
Diffstat (limited to 'package')
-rw-r--r--package/dnsmasq/Makefile2
-rw-r--r--package/dnsmasq/files/dhcp.conf2
-rw-r--r--package/dnsmasq/files/dnsmasq.init2
3 files changed, 5 insertions, 1 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index 3599fa09ad..5fe1509601 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_VERSION:=2.47
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
diff --git a/package/dnsmasq/files/dhcp.conf b/package/dnsmasq/files/dhcp.conf
index 837be313ee..f34a0e9158 100644
--- a/package/dnsmasq/files/dhcp.conf
+++ b/package/dnsmasq/files/dhcp.conf
@@ -12,6 +12,8 @@ config dnsmasq
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
#list server '/mycompany.local/1.2.3.4'
+ #option nonwildcard 0
+ #option interfaces ''
config dhcp lan
option interface lan
diff --git a/package/dnsmasq/files/dnsmasq.init b/package/dnsmasq/files/dnsmasq.init
index 870414900f..0b2f630390 100644
--- a/package/dnsmasq/files/dnsmasq.init
+++ b/package/dnsmasq/files/dnsmasq.init
@@ -57,6 +57,7 @@ dnsmasq() {
append_bool "$cfg" boguspriv "-b"
append_bool "$cfg" expandhosts "-E"
append_bool "$cfg" enable_tftp "--enable-tftp"
+ append_bool "$cfg" nonwildcard "-z"
append_parm "$cfg" dnsforwardmax "-0"
append_parm "$cfg" port "-p"
@@ -71,6 +72,7 @@ dnsmasq() {
append_parm "$cfg" "resolvfile" "-r"
append_parm "$cfg" "tftp_root" "--tftp-root"
append_parm "$cfg" "dhcp_boot" "--dhcp-boot"
+ append_parm "$cfg" "interfaces" "-i"
config_get leasefile $cfg leasefile
[ -e "$leasefile" ] || touch "$leasefile"