summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2008-07-17 01:09:49 +0000
committerAndy Boyett <agb@openwrt.org>2008-07-17 01:09:49 +0000
commitd549476c027e2aa6d8c8107cc61008fa03e94263 (patch)
tree66ac7e7a472a88ea354a11565f9d0bb7262a6ad2 /package
parent0fb8aa363f2972009439cee7351d1e2289652cdb (diff)
downloadmaster-31e0f0ae-d549476c027e2aa6d8c8107cc61008fa03e94263.tar.gz
master-31e0f0ae-d549476c027e2aa6d8c8107cc61008fa03e94263.tar.bz2
master-31e0f0ae-d549476c027e2aa6d8c8107cc61008fa03e94263.zip
Fix menuconfig - Description for the no timestamp check option was swallowing all entries below it in menuconfig
SVN-Revision: 11850
Diffstat (limited to 'package')
-rw-r--r--package/wpa_supplicant/Config.in9
-rw-r--r--package/wpa_supplicant/Makefile8
2 files changed, 10 insertions, 7 deletions
diff --git a/package/wpa_supplicant/Config.in b/package/wpa_supplicant/Config.in
new file mode 100644
index 0000000000..d3700fae84
--- /dev/null
+++ b/package/wpa_supplicant/Config.in
@@ -0,0 +1,9 @@
+# wpa_supplicant config
+config WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
+ bool "Disable timestamp check"
+ depends PACKAGE_wpa-supplicant
+ default n
+ help
+ This disables the timestamp check for certificates in wpa_supplicant
+ Useful for devices without RTC that cannot reliably get the real date/time
+
diff --git a/package/wpa_supplicant/Makefile b/package/wpa_supplicant/Makefile
index 0a72572886..1171ba00d3 100644
--- a/package/wpa_supplicant/Makefile
+++ b/package/wpa_supplicant/Makefile
@@ -31,13 +31,7 @@ define Package/wpa-supplicant/Description
endef
define Package/wpa-supplicant/config
- config WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
- bool "Disable timestamp check"
- depends PACKAGE_wpa-supplicant
- default n
- help
- This disables the timestamp check for certificates in wpa_supplicant
- Useful for devices without RTC that cannot reliably get the real date/time
+ source "$(SOURCE)/Config.in"
endef