summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorDaniel Dickinson <crazycshore@gmail.com>2011-04-04 11:30:01 +0000
committerDaniel Dickinson <crazycshore@gmail.com>2011-04-04 11:30:01 +0000
commitc319b73399547a5531d3b6fb219855fdc619ec1c (patch)
tree04600bac1c1badde227508d8656b2168cc010610 /package
parent581793d2c465474ae2591b78f6bb3f26c22e51a2 (diff)
downloadmaster-31e0f0ae-c319b73399547a5531d3b6fb219855fdc619ec1c.tar.gz
master-31e0f0ae-c319b73399547a5531d3b6fb219855fdc619ec1c.tar.bz2
master-31e0f0ae-c319b73399547a5531d3b6fb219855fdc619ec1c.zip
block-mount: Removed duplicated directory creation in the package install section. The duplicates were a result of the mergin the block-* packages.
SVN-Revision: 26469
Diffstat (limited to 'package')
-rw-r--r--package/block-mount/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/package/block-mount/Makefile b/package/block-mount/Makefile
index ba19071b7b..1d4f7368cf 100644
--- a/package/block-mount/Makefile
+++ b/package/block-mount/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=block-mount
PKG_VERSION:=0.2.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
include $(INCLUDE_DIR)/package.mk
@@ -50,7 +50,6 @@ define Package/block-mount/install
$(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/fstab.config $(1)/etc/config/fstab
- $(INSTALL_DIR) $(1)/lib/functions
$(INSTALL_DIR) $(1)/lib/functions/fsck
$(INSTALL_DATA) ./files/mount.sh $(1)/lib/functions/
$(INSTALL_DATA) ./files/fsck.sh $(1)/lib/functions/
@@ -59,13 +58,11 @@ define Package/block-mount/install
$(INSTALL_DATA) ./files/10-swap $(1)/etc/hotplug.d/block/
$(INSTALL_DATA) ./files/20-fsck $(1)/etc/hotplug.d/block/
$(INSTALL_DATA) ./files/40-mount $(1)/etc/hotplug.d/block/
- $(INSTALL_DIR) $(1)/lib/functions
$(INSTALL_DATA) ./files/extmount.sh $(1)/lib/functions/
$(INSTALL_DIR) $(1)/lib/preinit
$(INSTALL_DATA) ./files/50_determine_usb_root $(1)/lib/preinit/
$(INSTALL_DATA) ./files/55_determine_extroot_sysupgrade $(1)/lib/preinit/
$(INSTALL_DATA) ./files/60_pivot_usb_root $(1)/lib/preinit/
- $(INSTALL_DIR) $(1)/lib/preinit
echo "extroot_settle_time=\"$(CONFIG_EXTROOT_SETTLETIME)\"" >$(1)/lib/preinit/00_extroot.conf
$(INSTALL_DIR) $(1)/overlay
endef