summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-12-15 02:00:26 +0000
committerJohn Crispin <john@openwrt.org>2012-12-15 02:00:26 +0000
commitc2738a9559f434db5d28282051741e24298344af (patch)
tree99aab7406990250ab6e9480ab0861017a1749e90 /package
parent2c33df03761f366193eeb2c3ffd28dfea475de41 (diff)
downloadmaster-31e0f0ae-c2738a9559f434db5d28282051741e24298344af.tar.gz
master-31e0f0ae-c2738a9559f434db5d28282051741e24298344af.tar.bz2
master-31e0f0ae-c2738a9559f434db5d28282051741e24298344af.zip
move ltq-ifxos
SVN-Revision: 34692
Diffstat (limited to 'package')
-rw-r--r--package/ltq-ifxos/patches/120-fix_smp_lock.patch12
-rw-r--r--package/platform/lantiq/ltq-ifxos/Makefile (renamed from package/ltq-ifxos/Makefile)8
-rw-r--r--package/platform/lantiq/ltq-ifxos/patches/100-compat.patch (renamed from package/ltq-ifxos/patches/100-portability.patch)10
3 files changed, 14 insertions, 16 deletions
diff --git a/package/ltq-ifxos/patches/120-fix_smp_lock.patch b/package/ltq-ifxos/patches/120-fix_smp_lock.patch
deleted file mode 100644
index aea4305a90..0000000000
--- a/package/ltq-ifxos/patches/120-fix_smp_lock.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/src/linux/ifxos_linux_thread_drv.c
-+++ b/src/linux/ifxos_linux_thread_drv.c
-@@ -34,7 +34,9 @@
- #include <linux/sched.h>
- #include <linux/version.h>
- #include <linux/completion.h>
-+#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,33))
- #include <linux/smp_lock.h>
-+#endif
- #include <linux/signal.h>
-
-
diff --git a/package/ltq-ifxos/Makefile b/package/platform/lantiq/ltq-ifxos/Makefile
index eeca2010a0..1364849bc6 100644
--- a/package/ltq-ifxos/Makefile
+++ b/package/platform/lantiq/ltq-ifxos/Makefile
@@ -1,9 +1,7 @@
-#
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
-#
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
@@ -19,7 +17,9 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
include $(INCLUDE_DIR)/package.mk
define KernelPackage/ltq-ifxos
- SUBMENU:=Voice over IP
+ SECTION:=sys
+ CATEGORY:=Kernel modules
+ SUBMENU:=Libraries
TITLE:=Lantiq OS abstraction library
URL:=http://www.lantiq.com/
DEPENDS:=@TARGET_lantiq
diff --git a/package/ltq-ifxos/patches/100-portability.patch b/package/platform/lantiq/ltq-ifxos/patches/100-compat.patch
index d1ce7503a2..02f2da728e 100644
--- a/package/ltq-ifxos/patches/100-portability.patch
+++ b/package/platform/lantiq/ltq-ifxos/patches/100-compat.patch
@@ -9,3 +9,13 @@
AC_SUBST([KERNEL_BUILD_PATH],[$enableval])
else
AC_MSG_ERROR([The kernel build directory is not valid or not configured!])
+--- a/src/linux/ifxos_linux_thread_drv.c
++++ b/src/linux/ifxos_linux_thread_drv.c
+@@ -34,7 +34,6 @@
+ #include <linux/sched.h>
+ #include <linux/version.h>
+ #include <linux/completion.h>
+-#include <linux/smp_lock.h>
+ #include <linux/signal.h>
+
+