summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-05-23 13:07:44 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-05-23 13:07:44 +0000
commitc1ff8cd9bbece1ab0a9c21e8d656bc79ebe5eaa2 (patch)
treea9203d66f6fbd6cc1e15351dda350fbe9aabdc8e /package
parent10a697faafb8c5f644ee6ed85dee4a6652b330f1 (diff)
downloadmaster-31e0f0ae-c1ff8cd9bbece1ab0a9c21e8d656bc79ebe5eaa2.tar.gz
master-31e0f0ae-c1ff8cd9bbece1ab0a9c21e8d656bc79ebe5eaa2.tar.bz2
master-31e0f0ae-c1ff8cd9bbece1ab0a9c21e8d656bc79ebe5eaa2.zip
firewall3: update to git head
- Use weak references for instantiating libext*.a matches, makes fw3 independant from the compile time features of iptables - Do not leak memory when processing rules with unknown targets or matches SVN-Revision: 36698
Diffstat (limited to 'package')
-rw-r--r--package/network/config/firewall3/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/config/firewall3/Makefile b/package/network/config/firewall3/Makefile
index 73941dae2f..1ec8ae651d 100644
--- a/package/network/config/firewall3/Makefile
+++ b/package/network/config/firewall3/Makefile
@@ -14,7 +14,7 @@ PKG_RELEASE:=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/firewall3.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=c3a5b984f6cec4014c1120ee900a53b452eb9e32
+PKG_SOURCE_VERSION:=a93d95470803e9026c725fc7081ac8a06191ea6a
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
@@ -47,7 +47,7 @@ define Build/Compile
endef
TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_LDFLAGS += -Wl,--gc-sections -Wl,--whole-archive
define Package/firewall3/install
$(INSTALL_DIR) $(1)/sbin