summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-05-17 00:25:41 +0000
committerNicolas Thill <nico@openwrt.org>2009-05-17 00:25:41 +0000
commitc1a929efbd997e6b88a9db317cf513dc9fd59497 (patch)
tree9b42ddb30ea58e5412732f81a3bde9cfdee3cf49 /package
parent022e4a568e598c3ff36215465227d088fe4148f1 (diff)
downloadmaster-31e0f0ae-c1a929efbd997e6b88a9db317cf513dc9fd59497.tar.gz
master-31e0f0ae-c1a929efbd997e6b88a9db317cf513dc9fd59497.tar.bz2
master-31e0f0ae-c1a929efbd997e6b88a9db317cf513dc9fd59497.zip
openssl: fix annoying build errors when changing upstream versions
SVN-Revision: 15880
Diffstat (limited to 'package')
-rw-r--r--package/openssl/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 11a9ef2e28..55c9a1c623 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -93,8 +93,9 @@ endef
TARGET_CFLAGS += $(FPIC)
define Build/Compile
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
+ # XXX: OpenSSL "make depend" will look for installed headers before its own,
+ # so remove installed stuff first
+ -$(SUBMAKE) -j1 clean-staging
$(MAKE) -C $(PKG_BUILD_DIR) \
MAKEDEPPROG="$(TARGET_CROSS)gcc" \
OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \