summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2011-04-09 23:26:00 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2011-04-09 23:26:00 +0000
commitbe08c96f014092d395205784d6b908b14597f9f4 (patch)
treea47d9ec4c7f56a5327b1ab6ec9511e312e52f95b /package
parent24c1caef5f3778fc634bc0ef588f94bcffbd2a85 (diff)
downloadmaster-31e0f0ae-be08c96f014092d395205784d6b908b14597f9f4.tar.gz
master-31e0f0ae-be08c96f014092d395205784d6b908b14597f9f4.tar.bz2
master-31e0f0ae-be08c96f014092d395205784d6b908b14597f9f4.zip
sound: do not pack ac97_bus.ko and snd-ac97-codec.ko into two packages.
SVN-Revision: 26568
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/sound.mk31
1 files changed, 23 insertions, 8 deletions
diff --git a/package/kernel/modules/sound.mk b/package/kernel/modules/sound.mk
index da56f25e8b..b46f25128a 100644
--- a/package/kernel/modules/sound.mk
+++ b/package/kernel/modules/sound.mk
@@ -99,13 +99,29 @@ define AddDepends/sound
endef
+define KernelPackage/ac97
+ TITLE:=ac97 controller
+ KCONFIG:=CONFIG_SND_AC97_CODEC
+ FILES:= \
+ $(LINUX_DIR)/sound/ac97_bus.ko \
+ $(LINUX_DIR)/sound/pci/ac97/snd-ac97-codec.ko
+ AUTOLOAD:=$(call AutoLoad,35,ac97_bus snd-ac97-codec)
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/ac97/description
+ The ac97 controller
+endef
+
+$(eval $(call KernelPackage,ac97))
+
+
define KernelPackage/sound-i8x0
TITLE:=Intel/SiS/nVidia/AMD/ALi AC97 Controller
+ DEPENDS:=+kmod-ac97
KCONFIG:=CONFIG_SND_INTEL8X0
- FILES:=$(LINUX_DIR)/sound/pci/snd-intel8x0.ko \
- $(LINUX_DIR)/sound/ac97_bus.ko \
- $(LINUX_DIR)/sound/pci/ac97/snd-ac97-codec.ko
- AUTOLOAD:=$(call AutoLoad,35,ac97_bus snd-ac97-codec snd-intel8x0)
+ FILES:=$(LINUX_DIR)/sound/pci/snd-intel8x0.ko
+ AUTOLOAD:=$(call AutoLoad,36,snd-intel8x0)
$(call AddDepends/sound)
endef
@@ -120,11 +136,10 @@ $(eval $(call KernelPackage,sound-i8x0))
define KernelPackage/sound-cs5535audio
TITLE:=CS5535 PCI Controller
+ DEPENDS:=+kmod-ac97
KCONFIG:=CONFIG_SND_CS5535AUDIO
- FILES:=$(LINUX_DIR)/sound/pci/cs5535audio/snd-cs5535audio.ko \
- $(LINUX_DIR)/sound/ac97_bus.ko \
- $(LINUX_DIR)/sound/pci/ac97/snd-ac97-codec.ko
- AUTOLOAD:=$(call AutoLoad,35, ac97_bus snd-ac97-codec snd-cs5535audio)
+ FILES:=$(LINUX_DIR)/sound/pci/cs5535audio/snd-cs5535audio.ko
+ AUTOLOAD:=$(call AutoLoad,36,snd-cs5535audio)
$(call AddDepends/sound)
endef