summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-09-14 16:14:27 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-09-14 16:14:27 +0000
commitbc37b2e831db50b01eb038f5a5cb5a3dd6b3fe49 (patch)
treebc8c201a773b90c67ef1661b63c522bdac2d86e4 /package
parent8df03c85fe0b83e0a7508298591ae92b4c13c986 (diff)
downloadmaster-31e0f0ae-bc37b2e831db50b01eb038f5a5cb5a3dd6b3fe49.tar.gz
master-31e0f0ae-bc37b2e831db50b01eb038f5a5cb5a3dd6b3fe49.tar.bz2
master-31e0f0ae-bc37b2e831db50b01eb038f5a5cb5a3dd6b3fe49.zip
base-files: dispatch ifdown events for proto=none interfaces and fix a race condition between revert state and hotplug handlers
SVN-Revision: 17582
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/sbin/ifdown4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 4661a5a575..d87253b4dd 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=29
+PKG_RELEASE:=30
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/sbin/ifdown b/package/base-files/files/sbin/ifdown
index 883f8ec428..8de414d8b6 100755
--- a/package/base-files/files/sbin/ifdown
+++ b/package/base-files/files/sbin/ifdown
@@ -22,8 +22,8 @@ config_get proto "$cfg" proto
[ -z "$proto" ] && { echo "interface not found."; exit; }
config_get iface "$cfg" device
-[ "static" = "$proto" ] && {
- env -i ACTION="ifdown" INTERFACE="$cfg" DEVICE="$iface" PROTO=static /sbin/hotplug-call "iface" &
+[ "static" = "$proto" -o "none" = "$proto" ] && {
+ env -i ACTION="ifdown" INTERFACE="$cfg" DEVICE="$iface" PROTO="$proto" /sbin/hotplug-call "iface"
}
# call interface stop handler