summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-10-11 11:58:09 +0000
committerJohn Crispin <john@openwrt.org>2012-10-11 11:58:09 +0000
commitba6751058bba655af55afb431806d5e9c6f068aa (patch)
treeb182f8b00c90f94a630bdbb0f37f1c66300d9e5c /package
parent600ad59fb32fc5a36b87259b4a41ec812f420c7f (diff)
downloadmaster-31e0f0ae-ba6751058bba655af55afb431806d5e9c6f068aa.tar.gz
master-31e0f0ae-ba6751058bba655af55afb431806d5e9c6f068aa.tar.bz2
master-31e0f0ae-ba6751058bba655af55afb431806d5e9c6f068aa.zip
gpiodev/gpioctl RIP
SVN-Revision: 33725
Diffstat (limited to 'package')
-rw-r--r--package/gpioctl/Makefile43
-rw-r--r--package/gpioctl/src/Makefile24
-rw-r--r--package/gpioctl/src/main.c76
3 files changed, 0 insertions, 143 deletions
diff --git a/package/gpioctl/Makefile b/package/gpioctl/Makefile
deleted file mode 100644
index 50c4d3c659..0000000000
--- a/package/gpioctl/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-#
-# Copyright (C) 2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=gpioctl
-PKG_RELEASE:=1
-PKG_VERSION:=1.0
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/gpioctl
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=Tool for controlling gpio pins
- DEPENDS:=@GPIO_SUPPORT
-endef
-
-define Package/gpioctl/description
- Tool for controlling gpio pins
-endef
-
-define Build/Prepare
- mkdir -p $(PKG_BUILD_DIR)
- $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) CFLAGS="$(TARGET_CFLAGS) -I$(LINUX_DIR)/include"
-endef
-
-define Package/gpioctl/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/gpioctl $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,gpioctl))
diff --git a/package/gpioctl/src/Makefile b/package/gpioctl/src/Makefile
deleted file mode 100644
index 467697410a..0000000000
--- a/package/gpioctl/src/Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
-PROGS = gpioctl
-
-INSTDIR = $(prefix)/usr/bin
-INSTMODE = 0755
-INSTOWNER = root
-INSTGROUP = root
-
-OBJS = main.o
-
-all: $(PROGS)
-$(PROGS): $(OBJS)
- $(CC) $(CFLAGS) $(LDFLAGS) $^ $(LDLIBS) -o $@
- $(STRIP) $@
-
-%.o: %.c
- $(CC) -c $(CFLAGS) $^ -o $@
-
-install: $(PROGS)
- $(INSTALL) -d $(INSTDIR)
- $(INSTALL) -m $(INSTMODE) -o $(INSTOWNER) -g $(INSTGROUP) $(PROGS) $(INSTDIR)
-
-clean:
- rm -f $(PROGS) *.o core
-
diff --git a/package/gpioctl/src/main.c b/package/gpioctl/src/main.c
deleted file mode 100644
index 8ad27749b4..0000000000
--- a/package/gpioctl/src/main.c
+++ /dev/null
@@ -1,76 +0,0 @@
-/*
-* This program is free software; you can redistribute it and/or modify
-* it under the terms of the GNU General Public License as published by
-* the Free Software Foundation; either version 2 of the License, or
-* (at your option) any later version.
-*
-* This program is distributed in the hope that it will be useful,
-* but WITHOUT ANY WARRANTY; without even the implied warranty of
-* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-* GNU General Public License for more details.
-*
-* You should have received a copy of the GNU General Public License
-* along with this program; if not, write to the Free Software
-* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA02111-1307USA
-*
-* Feedback, Bugs... blogic@openwrt.org
-*
-*/
-
-#include <stdio.h>
-#include <stdlib.h>
-#include <sys/types.h>
-#include <sys/stat.h>
-#include <fcntl.h>
-#include <linux/gpio_dev.h>
-#include <linux/ioctl.h>
-
-void
-print_usage()
-{
- printf("gpioctl dirin|dirout|get|set|clear gpio\n");
- exit(0);
-}
-
-int
-main(int argc, char **argv)
-{
- int gpio_pin;
- int fd;
- int result = 0;
-
- if (argc != 3)
- {
- print_usage();
- }
-
- if ((fd = open("/dev/gpio", O_RDWR)) < 0)
- {
- printf("Error whilst opening /dev/gpio\n");
- return -1;
- }
-
- gpio_pin = atoi(argv[2]);
-
- printf("using gpio pin %d\n", gpio_pin);
-
- if (!strcmp(argv[1], "dirin"))
- {
- ioctl(fd, GPIO_DIR_IN, gpio_pin);
- } else if (!strcmp(argv[1], "dirout"))
- {
- ioctl(fd, GPIO_DIR_OUT, gpio_pin);
- } else if (!strcmp(argv[1], "get"))
- {
- result = ioctl(fd, GPIO_GET, gpio_pin);
- printf("Pin %d is %s\n", gpio_pin, (result ? "HIGH" : "LOW"));
- } else if (!strcmp(argv[1], "set"))
- {
- ioctl(fd, GPIO_SET, gpio_pin);
- } else if (!strcmp(argv[1], "clear"))
- {
- ioctl(fd, GPIO_CLEAR, gpio_pin);
- } else print_usage();
-
- return result;
-}