summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-08-13 03:31:53 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-08-13 03:31:53 +0000
commitb44b066543496c7dcead0df987a7f8cbae3ff3e0 (patch)
tree7d1585ea1e20ced50c3b8e3b7b0c5eb2f8ba0255 /package
parentf83925811c8d114616c507619332cba1a894004a (diff)
downloadmaster-31e0f0ae-b44b066543496c7dcead0df987a7f8cbae3ff3e0.tar.gz
master-31e0f0ae-b44b066543496c7dcead0df987a7f8cbae3ff3e0.tar.bz2
master-31e0f0ae-b44b066543496c7dcead0df987a7f8cbae3ff3e0.zip
firewall: allow incoming udp/68 packets in the default configuration (#4108, #4781)
SVN-Revision: 17238
Diffstat (limited to 'package')
-rw-r--r--package/firewall/Makefile2
-rw-r--r--package/firewall/files/firewall.config8
2 files changed, 9 insertions, 1 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index 7dcc2f5739..0f1b1118d7 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
include $(INCLUDE_DIR)/package.mk
diff --git a/package/firewall/files/firewall.config b/package/firewall/files/firewall.config
index 464540f990..5a4b5af436 100644
--- a/package/firewall/files/firewall.config
+++ b/package/firewall/files/firewall.config
@@ -22,6 +22,14 @@ config forwarding
option dest wan
option mtu_fix 1
+# We need to accept udp packets on port 68,
+# see https://dev.openwrt.org/ticket/4108
+config rule
+ option src wan
+ option proto udp
+ option dest_port 68
+ option target ACCEPT
+
# include a file with users custom iptables rules
config include
option path /etc/firewall.user