summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-03-02 04:56:49 +0000
committerNicolas Thill <nico@openwrt.org>2010-03-02 04:56:49 +0000
commitb3f90f939bff33fcfd980b16d9a5d63c20f55e5c (patch)
tree6f444b0eea9f74eacbfb8426cfe09e6bdee75b37 /package
parent45f7dc9459491cebf83e05c47d4c0b995fcd6439 (diff)
downloadmaster-31e0f0ae-b3f90f939bff33fcfd980b16d9a5d63c20f55e5c.tar.gz
master-31e0f0ae-b3f90f939bff33fcfd980b16d9a5d63c20f55e5c.tar.bz2
master-31e0f0ae-b3f90f939bff33fcfd980b16d9a5d63c20f55e5c.zip
openssl: fix build failure on arm, aes asm version is not shipped anymore (closes: #6778)
SVN-Revision: 19945
Diffstat (limited to 'package')
-rw-r--r--package/openssl/Makefile4
-rw-r--r--package/openssl/patches/310-arm_asm.patch12
2 files changed, 0 insertions, 16 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 3b99c08684..ef0edb0daf 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -82,11 +82,7 @@ else
OPENSSL_OPTIONS += no-engines
endif
-ifdef CONFIG_arm
-OPENSSL_MAKEFLAGS := AES_ASM_OBJ="aes-armv4.o aes_cbc.o"
-else
OPENSSL_OPTIONS += no-perlasm
-endif
define Build/Configure
(cd $(PKG_BUILD_DIR); \
diff --git a/package/openssl/patches/310-arm_asm.patch b/package/openssl/patches/310-arm_asm.patch
deleted file mode 100644
index 9b53a22c75..0000000000
--- a/package/openssl/patches/310-arm_asm.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/crypto/aes/Makefile
-+++ b/crypto/aes/Makefile
-@@ -47,6 +47,9 @@ lib: $(LIBOBJ)
-
- $(LIBOBJ): $(LIBSRC)
-
-+aes-armv4.s: asm/aes-armv4.pl
-+ $(PERL) $^ > $@
-+
- aes-ia64.s: asm/aes-ia64.S
- $(CC) $(CFLAGS) -E asm/aes-ia64.S > $@
-