summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-03 21:21:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-03 21:21:17 +0000
commitaee342712b66b702a70725ef3b8a481cfb32743f (patch)
treed8fc9d8e5631993c8897556820cfb8fae174cd48 /package
parent856e457b7301947f17866dc4a5aedb3f7117f163 (diff)
downloadmaster-31e0f0ae-aee342712b66b702a70725ef3b8a481cfb32743f.tar.gz
master-31e0f0ae-aee342712b66b702a70725ef3b8a481cfb32743f.tar.bz2
master-31e0f0ae-aee342712b66b702a70725ef3b8a481cfb32743f.zip
add i8x0 audio driver
Signed-off-by: Jan Willies <jan@willies.info> SVN-Revision: 9652
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/sound.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/modules/sound.mk b/package/kernel/modules/sound.mk
index 7faf387ba2..98e265fea7 100644
--- a/package/kernel/modules/sound.mk
+++ b/package/kernel/modules/sound.mk
@@ -69,3 +69,20 @@ endef
$(eval $(call KernelPackage,sound-core))
+define KernelPackage/sound-i8x0
+ SUBMENU:=$(SOUND_MENU)
+ TITLE:=Intel/SiS/nVidia/AMD/ALi AC97 Controller
+ DEPENDS:=kmod-sound-core
+ KCONFIG:=CONFIG_SND_INTEL8X0
+ FILES:=$(LINUX_DIR)/sound/pci/snd-intel8x0.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,35,snd-i8x0)
+endef
+
+define KernelPackage/sound-i8x0/description
+ support for the integrated AC97 sound device on motherboards
+ with Intel/SiS/nVidia/AMD chipsets, or ALi chipsets using
+ the M5455 Audio Controller.
+endef
+
+$(eval $(call KernelPackage,sound-i8x0))
+