summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-11-11 18:40:43 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-11-11 18:40:43 +0000
commitae912505ac7bb3f9b6c6eab8cd3cefb79d3dadc4 (patch)
tree6dd3ff0253805a46ab417b35ae3bf45d6b8e395e /package
parentcadd36a303c68ea298552add937903e9bd1ed89a (diff)
downloadmaster-31e0f0ae-ae912505ac7bb3f9b6c6eab8cd3cefb79d3dadc4.tar.gz
master-31e0f0ae-ae912505ac7bb3f9b6c6eab8cd3cefb79d3dadc4.tar.bz2
master-31e0f0ae-ae912505ac7bb3f9b6c6eab8cd3cefb79d3dadc4.zip
i2c-gpio-mux: fix build for 3.6+ kernels
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 34152
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/i2c.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/kernel/modules/i2c.mk b/package/kernel/modules/i2c.mk
index 6c65989683..49d8250777 100644
--- a/package/kernel/modules/i2c.mk
+++ b/package/kernel/modules/i2c.mk
@@ -197,8 +197,13 @@ endef
$(eval $(call KernelPackage,i2c-mux))
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.6.0)),1)
+I2C_MUX_GPIO_MODULES:= \
+ CONFIG_I2C_MUX_GPIO:drivers/i2c/muxes/i2c-mux-gpio
+else
I2C_MUX_GPIO_MODULES:= \
CONFIG_I2C_MUX_GPIO:drivers/i2c/muxes/gpio-i2cmux
+endif
define KernelPackage/i2c-mux-gpio
$(call i2c_defaults,$(I2C_MUX_GPIO_MODULES),51)