summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-08-06 00:58:49 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-08-06 00:58:49 +0000
commitae8dbcbae44f3bc5e5ca8fbad9676b55fd524161 (patch)
tree23c6f4836d857fde77fce50d5e3a461864e7f934 /package
parent2caa5916aa35c01747034773470c595c91312970 (diff)
downloadmaster-31e0f0ae-ae8dbcbae44f3bc5e5ca8fbad9676b55fd524161.tar.gz
master-31e0f0ae-ae8dbcbae44f3bc5e5ca8fbad9676b55fd524161.tar.bz2
master-31e0f0ae-ae8dbcbae44f3bc5e5ca8fbad9676b55fd524161.zip
kernel: package L2TP v3 ("Pseudowire") modules, restrict them to 2.6.35
SVN-Revision: 22501
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/netsupport.mk50
1 files changed, 50 insertions, 0 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 4f024f2be0..effd6930fd 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -624,3 +624,53 @@ endef
$(eval $(call KernelPackage,pktgen))
+define KernelPackage/l2tp
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ DEPENDS:=@LINUX_2_6_35
+ TITLE:=L2TPv3 Support
+ KCONFIG:=CONFIG_L2TP
+ FILES:=$(LINUX_DIR)/net/l2tp/l2tp_core.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,32,l2tp_core)
+endef
+
+define KernelPackage/l2tp/description
+ Kernel modules for L2TP V3 Support
+endef
+
+$(eval $(call KernelPackage,l2tp))
+
+define KernelPackage/l2tp-eth
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=L2TP ethernet pseudowire support for L2TPv3
+ DEPENDS:=+kmod-l2tp
+ KCONFIG:= CONFIG_L2TP_V3=y \
+ CONFIG_L2TP_ETH
+ FILES:= \
+ $(LINUX_DIR)/net/l2tp/l2tp_netlink.$(LINUX_KMOD_SUFFIX) \
+ $(LINUX_DIR)/net/l2tp/l2tp_eth.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,32,l2tp_core l2tp_netlink l2tp_eth)
+endef
+
+define KernelPackage/l2tp-eth/description
+ Kernel modules for L2TP V3 pseudowire support
+endef
+
+$(eval $(call KernelPackage,l2tp-eth))
+
+define KernelPackage/l2tp-ip
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Support for L2TP-over-IP socket family
+ DEPENDS:=+kmod-l2tp
+ KCONFIG:= CONFIG_L2TP_V3=y \
+ CONFIG_L2TP_IP
+ FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ip.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,32,l2tp_core l2tp_ip)
+endef
+
+define KernelPackage/l2tp-ip/description
+ Kernel modules for L2TP-over-IP socket family
+endef
+
+$(eval $(call KernelPackage,l2tp-ip))
+
+