summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-11-18 19:38:50 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-11-18 19:38:50 +0000
commitae87ca9a832adb53c6120d68e2a51499d6863c20 (patch)
treee1c4c384714f297a96aa49f6f49e5b1d5740f3e5 /package
parentdb7816235bc01d493d611f58d8c4d0d6894c85af (diff)
downloadmaster-31e0f0ae-ae87ca9a832adb53c6120d68e2a51499d6863c20.tar.gz
master-31e0f0ae-ae87ca9a832adb53c6120d68e2a51499d6863c20.tar.bz2
master-31e0f0ae-ae87ca9a832adb53c6120d68e2a51499d6863c20.zip
kernel/modules: move ixp4xx hardware crypto module package into crypto.mk
SVN-Revision: 13281
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/crypto.mk20
-rw-r--r--package/kernel/modules/other.mk19
2 files changed, 19 insertions, 20 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index 8bb57816c0..a63f855d51 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -30,7 +30,7 @@ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.26)),1)
SHA512_SUFFIX:=$(CRYPTO_GENERIC)
endif
-# XXX: added CONFIG_CRYPTO_HMAC to KCONFIG so that CONFIG_CRYPTO_HASH is
+# XXX: added CONFIG_CRYPTO_HMAC to KCONFIG so that CONFIG_CRYPTO_HASH is
# always set, even if no hash modules are selected
define KernelPackage/crypto-core
SUBMENU:=$(CRYPTO_MENU)
@@ -116,6 +116,24 @@ endef
$(eval $(call KernelPackage,crypto-hw-hifn-795x))
+define KernelPackage/crypto-hw-ixp4xx
+ SUBMENU:=$(CRYPTO_MENU)
+ TITLE:=Intel IXP4xx hardware crypto module
+ DEPENDS:= \
+ @TARGET_ixp4xx +kmod-crypto-core +kmod-crypto-des +kmod-crypto-aead \
+ +kmod-crypto-authenc
+ KCONFIG:= CONFIG_CRYPTO_DEV_IXP4XX
+ FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
+endef
+
+define KernelPackage/crypto-hw-ixp4xx/description
+ Kernel support for the Intel IXP4xx HW crypto engine.
+endef
+
+$(eval $(call KernelPackage,crypto-hw-ixp4xx))
+
+
define KernelPackage/crypto-aes
SUBMENU:=$(CRYPTO_MENU)
TITLE:=AES cipher CryptoAPI module
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index bcfb448544..513517d26c 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -681,22 +681,3 @@ define KernelPackage/spi-dev/description
endef
$(eval $(call KernelPackage,spi-dev))
-
-define KernelPackage/crypto-dev-ixp4xx
- SUBMENU:=$(OTHER_MENU)
- TITLE:=IXP4xx crypto driver
- DEPENDS:=\
- @TARGET_ixp4xx +kmod-crypto-core +kmod-crypto-des +kmod-crypto-aead \
- +kmod-crypto-authenc
- KCONFIG:=\
- CONFIG_CRYPTO_HW=y \
- CONFIG_CRYPTO_DEV_IXP4XX
- FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
-endef
-
-define KernelPackage/crypto-dev-ixp4xx/description
- Kernel support for the IXP4xx HW crypto engine.
-endef
-
-$(eval $(call KernelPackage,crypto-dev-ixp4xx))