summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2011-10-28 13:11:06 +0000
committerNicolas Thill <nico@openwrt.org>2011-10-28 13:11:06 +0000
commita13f6a4b75f31140bf76a1ac9bb40e16e4542a2f (patch)
tree19642e57f6c4624a6935b19e1cd79ffe0eb60e7d /package
parent1f1ae372ddf8045045862371aa37657459a5f981 (diff)
downloadmaster-31e0f0ae-a13f6a4b75f31140bf76a1ac9bb40e16e4542a2f.tar.gz
master-31e0f0ae-a13f6a4b75f31140bf76a1ac9bb40e16e4542a2f.tar.bz2
master-31e0f0ae-a13f6a4b75f31140bf76a1ac9bb40e16e4542a2f.zip
package/kernel: remove SetDepends not needed anymore
SVN-Revision: 28653
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/001-depends.mk25
-rw-r--r--package/kernel/modules/lib.mk1
-rw-r--r--package/kernel/modules/other.mk2
3 files changed, 4 insertions, 24 deletions
diff --git a/package/kernel/modules/001-depends.mk b/package/kernel/modules/001-depends.mk
index 238799e2e5..93aaeb33fb 100644
--- a/package/kernel/modules/001-depends.mk
+++ b/package/kernel/modules/001-depends.mk
@@ -1,37 +1,20 @@
#
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-# XXX: xburst has CONFIG_CRC16=y because of CONFIG_UBIFS_FS=y
-
-define SetDepends/crc16
- DEPENDS:= @!TARGET_xburst
-endef
-
define AddDepends/crc16
- DEPENDS+= +!TARGET_xburst:kmod-crc16 $(1)
-endef
-
-
-define SetDepends/hid
- DEPENDS:= @!TARGET_x86
+ DEPENDS+= +kmod-crc16 $(1)
endef
define AddDepends/hid
- DEPENDS+= +!TARGET_x86:kmod-hid $(1)
-
-endef
-
-
-define SetDepends/input
- DEPENDS:= @!(TARGET_x86_generic||TARGET_x86_kvm_guest)
+ DEPENDS+= +kmod-hid $(1)
endef
define AddDepends/input
- DEPENDS+= +!(TARGET_x86_generic||TARGET_x86_kvm_guest):kmod-input-core $(1)
+ DEPENDS+= +kmod-input-core $(1)
endef
diff --git a/package/kernel/modules/lib.mk b/package/kernel/modules/lib.mk
index 9154b2eade..4b9eed45e2 100644
--- a/package/kernel/modules/lib.mk
+++ b/package/kernel/modules/lib.mk
@@ -58,7 +58,6 @@ define KernelPackage/crc16
KCONFIG:=CONFIG_CRC16
FILES:=$(LINUX_DIR)/lib/crc16.ko
AUTOLOAD:=$(call AutoLoad,20,crc16,1)
- $(call SetDepends/crc16)
endef
define KernelPackage/crc16/description
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index dcab71fa23..951f7ac944 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -260,7 +260,6 @@ define KernelPackage/hid
KCONFIG:=CONFIG_HID
FILES:=$(LINUX_DIR)/drivers/hid/hid.ko
AUTOLOAD:=$(call AutoLoad,61,hid)
- $(call SetDepends/hid)
$(call AddDepends/input,+kmod-input-evdev)
endef
@@ -275,7 +274,6 @@ define KernelPackage/input-core
SUBMENU:=$(OTHER_MENU)
TITLE:=Input device core
KCONFIG:=CONFIG_INPUT
- $(call SetDepends/input)
FILES:=$(LINUX_DIR)/drivers/input/input-core.ko
AUTOLOAD:=$(call AutoLoad,19,input-core)
endef