summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-01-05 15:28:16 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-01-05 15:28:16 +0000
commit9ec6cf29392a5d14cb5bd8cb523199fbc9c252c6 (patch)
tree8218685575dab21f0e0f1e02ff23c3ec82e0fa85 /package
parent5b5c64e8fd280c24d4f7b0bf894de3d8bc16b5b2 (diff)
downloadmaster-31e0f0ae-9ec6cf29392a5d14cb5bd8cb523199fbc9c252c6.tar.gz
master-31e0f0ae-9ec6cf29392a5d14cb5bd8cb523199fbc9c252c6.tar.bz2
master-31e0f0ae-9ec6cf29392a5d14cb5bd8cb523199fbc9c252c6.zip
Add i2c kernel modules for Au1000 i2c to gpio driver, can be extended later
SVN-Revision: 5984
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/i2c.mk43
1 files changed, 43 insertions, 0 deletions
diff --git a/package/kernel/modules/i2c.mk b/package/kernel/modules/i2c.mk
new file mode 100644
index 0000000000..abf6040158
--- /dev/null
+++ b/package/kernel/modules/i2c.mk
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id $
+
+I2CMENU:=I2C Bus
+
+define KernelPackage/i2c-core
+ TITLE:=I2C support
+ DESCRIPTION:=Kernel modules for i2c support
+ SUBMENU:=$(I2CMENU)
+ KCONFIG:=$(CONFIG_I2C_CORE) \
+ $(CONFIG_I2C_DEV)
+ FILES:=$(MODULES_DIR)/kernel/drivers/i2c/*.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,i2c-core i2c-dev)
+endef
+$(eval $(call KernelPackage,i2c-core))
+
+define KernelPackage/i2c-algos
+ TITLE:=I2C algorithms support
+ DESCRIPTION:=Kernel modules for various i2c algorithms
+ SUBMENU:=$(I2CMENU)
+ KCONFIG:=$(CONFIG_I2C_ALGOBIT)
+ FILES:=$(MODULES_DIR)/kernel/drivers/i2c/algos/*.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,60,i2c-algo-bit i2c-algo-pcf i2c-algo-pca)
+endef
+$(eval $(call KernelPackage,i2c-algos))
+
+define KernelPackage/i2c-au1x00gpio
+ TITLE:=I2C GPIO interface for Au1x00 devices
+ DESCRIPTION:=I2C GPIO interface for Au1x00 devices
+ DEFAULT:=y if LINUX_2_6_AU1000
+ DEPENDS:=+kmod-i2c-core +kmod-i2c-algos
+ SUBMENU:=$(I2CMENU)
+ KCONFIG:=$(CONFIG_I2C_AU1X00GPIO)
+ FILES:=$(MODULES_DIR)/kernel/drivers/i2c/busses/i2c-au1x00gpio.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call Autoload,70,i2c-au1x00gpio)
+endef
+$(eval $(call KernelPackage,i2c-au1x00gpio))
+