summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-07-18 13:08:27 +0000
committerJonas Gorski <jogo@openwrt.org>2013-07-18 13:08:27 +0000
commit9a38971a3e2d202f7dfa68388481fcba72097bf4 (patch)
tree1028152a3d045b8cd3b3e5ea7285a849a7f8c77d /package
parent5b931b9ec0eccc41b2e6ca8b0addb0ee84d262e6 (diff)
downloadmaster-31e0f0ae-9a38971a3e2d202f7dfa68388481fcba72097bf4.tar.gz
master-31e0f0ae-9a38971a3e2d202f7dfa68388481fcba72097bf4.tar.bz2
master-31e0f0ae-9a38971a3e2d202f7dfa68388481fcba72097bf4.zip
kernel: crypto: add missing dependencies and files
Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 37392
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/crypto.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 065ddbfecb..241b596a5d 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -164,7 +164,7 @@ $(eval $(call KernelPackage,crypto-hw-geode))
define KernelPackage/crypto-hw-hifn-795x
TITLE:=HIFN 795x crypto accelerator
- DEPENDS:=+kmod-random-core
+ DEPENDS:=+kmod-random-core +kmod-crypto-manager
KCONFIG:= \
CONFIG_CRYPTO_DEV_HIFN_795X \
CONFIG_CRYPTO_DEV_HIFN_795X_RNG=y
@@ -386,6 +386,7 @@ define KernelPackage/crypto-misc
FILES:= \
$(LINUX_DIR)/crypto/anubis.ko \
$(LINUX_DIR)/crypto/camellia$(camellia_mod_suffix).ko \
+ $((if $(call kernel_patchver_ge,3.7),$(LINUX_DIR)/crypto/cast_common.ko) \
$(LINUX_DIR)/crypto/cast5$(cast56_mod_suffix).ko \
$(LINUX_DIR)/crypto/cast6$(cast56_mod_suffix).ko \
$(LINUX_DIR)/crypto/fcrypt.ko \
@@ -464,7 +465,7 @@ define KernelPackage/crypto-null
KCONFIG:=CONFIG_CRYPTO_NULL
FILES:=$(LINUX_DIR)/crypto/crypto_null.ko
AUTOLOAD:=$(call AutoLoad,09,crypto_null)
- $(call AddDepends/crypto)
+ $(call AddDepends/crypto,+kmod-crypto-manager)
endef
$(eval $(call KernelPackage,crypto-null))
@@ -474,7 +475,7 @@ define KernelPackage/crypto-test
TITLE:=Test CryptoAPI module
KCONFIG:=CONFIG_CRYPTO_TEST
FILES:=$(LINUX_DIR)/crypto/tcrypt.ko
- $(call AddDepends/crypto)
+ $(call AddDepends/crypto,+kmod-crypto-manager)
endef
$(eval $(call KernelPackage,crypto-test))