summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-14 00:52:15 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-14 00:52:15 +0000
commit985ee9fc8fd1aa23e5a19f65f10873fd7f4e9c91 (patch)
tree37dd758fe9d6ad4cdfe468d2076850f516c54fbc /package
parent2da3f6a25641ed7442141ce07943afaaad3b8c31 (diff)
downloadmaster-31e0f0ae-985ee9fc8fd1aa23e5a19f65f10873fd7f4e9c91.tar.gz
master-31e0f0ae-985ee9fc8fd1aa23e5a19f65f10873fd7f4e9c91.tar.bz2
master-31e0f0ae-985ee9fc8fd1aa23e5a19f65f10873fd7f4e9c91.zip
LED driver for PCEngines ALIX boards
This patch adds a driver for the three LEDs that exists on the PCEngines ALIX 2 and 3 series boards. The driver is also added to the Alix profile. Signed-off-by: Petr Liebman <petrliebman@gmail.com> -- SVN-Revision: 9748
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index ba6f6f89bd..ebf4d066cb 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -334,6 +334,22 @@ endef
$(eval $(call KernelPackage,leds-wrap))
+define KernelPackage/leds-alix
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=PCengines ALIX LED support
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_LEDS_ALIX
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-alix.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,leds-alix)
+endef
+
+define KernelPackage/leds-alix/description
+ Kernel module for PCengines ALIX LEDs
+endef
+
+$(eval $(call KernelPackage,leds-alix))
+
+
define KernelPackage/ledtrig-morse
SUBMENU:=$(OTHER_MENU)
TITLE:=LED Morse Trigger