summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-02-16 19:11:38 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-02-16 19:11:38 +0000
commit9034bd32af37c11869858e776198a8980139f39d (patch)
tree1047d9cd69fc45976b75418bf4defb991a3fcfdb /package
parent44253d311f4e5d22c1bb1b5882431e36e5c44f3a (diff)
downloadmaster-31e0f0ae-9034bd32af37c11869858e776198a8980139f39d.tar.gz
master-31e0f0ae-9034bd32af37c11869858e776198a8980139f39d.tar.bz2
master-31e0f0ae-9034bd32af37c11869858e776198a8980139f39d.zip
mac80211: brcmfmac: Add SDIO support option
This patch adds SDIO support for the brcmfmac driver. For now only very few boards need it. Signed off by: José Vázquez Fernández <ppvazquezfer@gmail.com> Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 44465
Diffstat (limited to 'package')
-rw-r--r--package/kernel/mac80211/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 814eb1cf6d..4ea2f3dc91 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1488,6 +1488,21 @@ define KernelPackage/brcmfmac/description
Kernel module for Broadcom IEEE802.11n USB Wireless cards
endef
+define KernelPackage/brcmfmac/config
+ if PACKAGE_kmod-brcmfmac
+
+ config BRCMFMAC_SDIO
+ bool "Enable SDIO support"
+ default n
+ help
+ Enable support for cards attached to an SDIO bus.
+ Select this option only if you are sure that your
+ board has a Broadcom wireless chip atacched to
+ that bus.
+
+ endif
+endef
+
config_package=$(if $(CONFIG_PACKAGE_kmod-$(1)),m)
config-y:= \
@@ -1558,6 +1573,7 @@ config-y += B43LEGACY_DMA_MODE
config-$(call config_package,brcmutil) += BRCMUTIL
config-$(call config_package,brcmsmac) += BRCMSMAC
config-$(call config_package,brcmfmac) += BRCMFMAC
+config-$(CONFIG_BRCMFMAC_SDIO) += BRCMFMAC_SDIO
config-y += BRCMFMAC_USB
config-$(CONFIG_PACKAGE_BRCM80211_DEBUG) += BRCMDBG