summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-02-05 23:18:47 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-02-05 23:18:47 +0000
commit8f7ce3aa6ddaa94eb1fa1fca47f1f6b34b839412 (patch)
tree870fb7c436d28f9c7a9498d70e6a0502db09e97b /package
parent66fe4fd966cadf9b2a2fa3af75bd8aba63daa918 (diff)
downloadmaster-31e0f0ae-8f7ce3aa6ddaa94eb1fa1fca47f1f6b34b839412.tar.gz
master-31e0f0ae-8f7ce3aa6ddaa94eb1fa1fca47f1f6b34b839412.tar.bz2
master-31e0f0ae-8f7ce3aa6ddaa94eb1fa1fca47f1f6b34b839412.zip
mac80211: don't hardcode /bin/bash
Instead of hardcoding /bin/bash, use /usr/bin/env bash - this fixes the build on FreeBSD 10.1. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44283
Diffstat (limited to 'package')
-rw-r--r--package/kernel/mac80211/patches/001-fix_build.patch9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/kernel/mac80211/patches/001-fix_build.patch b/package/kernel/mac80211/patches/001-fix_build.patch
index 99ef50e182..3c3efdd5a1 100644
--- a/package/kernel/mac80211/patches/001-fix_build.patch
+++ b/package/kernel/mac80211/patches/001-fix_build.patch
@@ -1,5 +1,14 @@
--- a/Makefile
+++ b/Makefile
+@@ -5,7 +5,7 @@
+ ifeq ($(KERNELRELEASE),)
+
+ MAKEFLAGS += --no-print-directory
+-SHELL := /bin/bash
++SHELL := /usr/bin/env bash
+ BACKPORT_PWD := $(shell pwd)
+
+ KMODDIR ?= updates
@@ -19,6 +19,7 @@ KLIB_BUILD ?= $(KLIB)/build/
KERNEL_CONFIG := $(KLIB_BUILD)/.config
KERNEL_MAKEFILE := $(KLIB_BUILD)/Makefile