summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-09-19 11:18:00 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-09-19 11:18:00 +0000
commit8e9736675fd4b799cb0154a475bab427e7623678 (patch)
tree66b14518925da16dedcd5e6738ab713fdc99853d /package
parentaea8213bdd9dddea0448bf9206f2db513e0a64cd (diff)
downloadmaster-31e0f0ae-8e9736675fd4b799cb0154a475bab427e7623678.tar.gz
master-31e0f0ae-8e9736675fd4b799cb0154a475bab427e7623678.tar.bz2
master-31e0f0ae-8e9736675fd4b799cb0154a475bab427e7623678.zip
Fix missing dependency in solos-pci module
Modinfo for solos-pci tells us that it has a dependency on "atm", but this isn't captured in the Makefile. Signed-off-by: Philip A. Prindeville <philipp_subx@redfish-solutions.com> SVN-Revision: 23086
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/netdevices.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/modules/netdevices.mk b/package/kernel/modules/netdevices.mk
index aaee3acce8..61fccf4fd7 100644
--- a/package/kernel/modules/netdevices.mk
+++ b/package/kernel/modules/netdevices.mk
@@ -489,7 +489,7 @@ $(eval $(call KernelPackage,tulip))
define KernelPackage/solos-pci
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Solos ADSL2+ multiport modem
- DEPENDS:=@TARGET_x86
+ DEPENDS:=@TARGET_x86 +kmod-atm
KCONFIG:=CONFIG_ATM_SOLOS
FILES:=$(LINUX_DIR)/drivers/atm/solos-pci.ko
AUTOLOAD:=$(call AutoLoad,50,solos-pci)