summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-07-23 19:49:19 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-07-23 19:49:19 +0000
commit8c1d9afc409fa26245256b91eb045a2f50f54c92 (patch)
tree65903012d23f729041ca23154b1ebc11003b9d7b /package
parent4ee3ae96c2fc373a91c2ea38fa62a4f000112ddf (diff)
downloadmaster-31e0f0ae-8c1d9afc409fa26245256b91eb045a2f50f54c92.tar.gz
master-31e0f0ae-8c1d9afc409fa26245256b91eb045a2f50f54c92.tar.bz2
master-31e0f0ae-8c1d9afc409fa26245256b91eb045a2f50f54c92.zip
use host opkg for installing packages in buildroot and ImageBuilder
SVN-Revision: 22372
Diffstat (limited to 'package')
-rw-r--r--package/Makefile12
-rw-r--r--package/opkg/Makefile24
2 files changed, 32 insertions, 4 deletions
diff --git a/package/Makefile b/package/Makefile
index 5468bdc718..530405cd06 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -20,6 +20,9 @@ ifneq ($(IGNORE_ERRORS),)
$(curdir)/builddirs-ignore-compile:= $(if $(filter m y, $(IGNORE_ERRORS)),$(foreach m,$(IGNORE_ERRORS),$(package-$(m))),$(package-m))
endif
+$(curdir)/opkghost: $(TMP_DIR)/.build
+ @-$(MAKE) package/opkg/host/install
+
$(curdir)/install:=$(curdir)/install-cleanup
$(curdir)/cleanup: $(TMP_DIR)/.build
@@ -88,9 +91,10 @@ $(curdir)/index: FORCE
$(curdir)/flags-install:= -j1
$(eval $(call stampfile,$(curdir),package,prereq,.config))
-$(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build))
-$(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build))
-$(eval $(call stampfile,$(curdir),package,install,$(TMP_DIR)/.build))
-$(eval $(call stampfile,$(curdir),package,rootfs-prepare,$(TMP_DIR)/.build))
+$(eval $(call stampfile,$(curdir),package,cleanup))
+$(eval $(call stampfile,$(curdir),package,compile))
+$(eval $(call stampfile,$(curdir),package,opkghost))
+$(eval $(call stampfile,$(curdir),package,install,$(STAGING_DIR)/stamp/.package_opkghost))
+$(eval $(call stampfile,$(curdir),package,rootfs-prepare))
$(eval $(call subdir,$(curdir)))
diff --git a/package/opkg/Makefile b/package/opkg/Makefile
index c18f8e7319..3a5ba449f1 100644
--- a/package/opkg/Makefile
+++ b/package/opkg/Makefile
@@ -18,7 +18,9 @@ PKG_SOURCE_SUBDIR:=opkg-$(PKG_VERSION)
PKG_SOURCE_URL:=http://opkg.googlecode.com/svn/trunk/
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
PKG_FIXUP = libtool
+
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
define Package/opkg
SECTION:=base
@@ -80,3 +82,25 @@ define Build/InstallDev
endef
$(eval $(call BuildPackage,opkg))
+
+
+HOST_CONFIGURE_ARGS += \
+ --disable-curl \
+ --disable-gpg \
+ --with-opkgetcdir=/etc \
+ --with-opkglockfile=/tmp/opkg.lock
+
+define Host/Configure
+ (cd $(HOST_BUILD_DIR); autoreconf -v --install || exit 1)
+ $(call Host/Configure/Default)
+endef
+
+define Host/Compile
+ $(MAKE) -C $(HOST_BUILD_DIR) CC="$(HOSTCC)" all
+endef
+
+define Host/Install
+ $(INSTALL_BIN) $(HOST_BUILD_DIR)/src/opkg-cl $(STAGING_DIR_HOST)/bin/opkg
+endef
+
+$(eval $(call HostBuild))