summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-21 06:59:10 +0000
committerJohn Crispin <john@openwrt.org>2015-04-21 06:59:10 +0000
commit87ef12fad30031155cfe9736b8b2a45a0c734bea (patch)
treebd9654e3ee659abdda159306c2cbffd7d66671fc /package
parent48d81861a620c8c4a6a9ffc9a9438290330ec1fb (diff)
downloadmaster-31e0f0ae-87ef12fad30031155cfe9736b8b2a45a0c734bea.tar.gz
master-31e0f0ae-87ef12fad30031155cfe9736b8b2a45a0c734bea.tar.bz2
master-31e0f0ae-87ef12fad30031155cfe9736b8b2a45a0c734bea.zip
wpan: rework bluetooth / wpan and 6lowpan dependencies
- remove/rename of 6lowpan-iphc upstream change in 3.17: 6lowpan: introduce new net/6lowpan directory id: 2c6bed7cfcd3f594ed9e4d6919fa2ebea2243d19 Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> SVN-Revision: 45529
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk30
-rw-r--r--package/kernel/linux/modules/wpan.mk8
2 files changed, 18 insertions, 20 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index a93583bf74..a7084c8d07 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -10,25 +10,25 @@ OTHER_MENU:=Other modules
WATCHDOG_DIR:=watchdog
-define KernelPackage/6lowpan-iphc
- USBMENU:=$(OTHER_MENU)
- TITLE:=6lowpan shared code
- KCONFIG:=CONFIG_6LOWPAN_IPHC
- HIDDEN:=1
- FILES:=$(LINUX_DIR)/net/ieee802154/6lowpan_iphc.ko
- AUTOLOAD:=$(call Autoprobe,6lowpan_iphc)
+define KernelPackage/6lowpan
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=6LoWPAN shared code
+ KCONFIG:=CONFIG_6LOWPAN
+ FILES:=$(LINUX_DIR)/net/6lowpan/6lowpan.ko
+ AUTOLOAD:=$(call AutoProbe,6lowpan)
endef
-define KernelPackage/6lowpan-iphc/description
+define KernelPackage/6lowpan/description
Shared 6lowpan code for IEEE 802.15.4 and Bluetooth.
endef
-$(eval $(call KernelPackage,6lowpan-iphc))
+$(eval $(call KernelPackage,6lowpan))
+
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-6lowpan-iphc +kmod-lib-crc16 +kmod-hid
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-lib-crc16 +kmod-hid
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \
@@ -70,13 +70,9 @@ $(eval $(call KernelPackage,bluetooth))
define KernelPackage/bluetooth_6lowpan
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth 6LoWPAN support
- DEPENDS:=+kmod-bluetooth
- KCONFIG:= \
- CONFIG_6LOWPAN=m \
- CONFIG_BT_6LOWPAN=m
- FILES:= \
- $(LINUX_DIR)/net/bluetooth/bluetooth_6lowpan.ko \
- $(LINUX_DIR)/net/6lowpan/6lowpan.ko
+ DEPENDS:=+kmod-6lowpan +kmod-bluetooth
+ KCONFIG:=CONFIG_BT_6LOWPAN
+ FILES:=$(LINUX_DIR)/net/bluetooth/bluetooth_6lowpan.ko
AUTOLOAD:=$(call AutoProbe,bluetooth)
endef
diff --git a/package/kernel/linux/modules/wpan.mk b/package/kernel/linux/modules/wpan.mk
index 0b1f33aaf3..f544f614bb 100644
--- a/package/kernel/linux/modules/wpan.mk
+++ b/package/kernel/linux/modules/wpan.mk
@@ -15,7 +15,7 @@ define KernelPackage/ieee802154
CONFIG_IEEE802154_SOCKET=y
FILES:= \
$(LINUX_DIR)/net/ieee802154/ieee802154.ko \
- $(LINUX_DIR)/net/ieee802154/ieee802154_socket.ko
+ $(LINUX_DIR)/net/ieee802154/ieee802154_socket.ko@ge4.0
AUTOLOAD:=$(call AutoLoad,90,ieee802154 ieee802154_socket)
endef
@@ -108,9 +108,11 @@ $(eval $(call KernelPackage,cc2520))
define KernelPackage/ieee802154_6lowpan
SUBMENU:=$(WPAN_MENU)
TITLE:= 6LoWPAN support over IEEE-802.15.4
- DEPENDS:=@LINUX_4_0
+ DEPENDS:=@LINUX_4_0 +kmod-6lowpan
KCONFIG:=CONFIG_IEEE802154_6LOWPAN
- FILES:=$(LINUX_DIR)/net/ieee802154/6lowpan/ieee802154_6lowpan.ko
+ FILES:= \
+ $(LINUX_DIR)/net/ieee802154/6lowpan/ieee802154_6lowpan.ko@ge4.0 \
+ $(LINUX_DIR)/net/ieee802154/ieee802154_6lowpan.ko@lt4.0
AUTOLOAD:=$(call AutoLoad,91,ieee802154_6lowpan)
endef