summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-03-04 15:53:51 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-03-04 15:53:51 +0000
commit8533636d2d106ed19c752239c866fc89bcefffc2 (patch)
tree7a640d4bb685d0156d58f7aee84005bbe884cc8b /package
parent086cae30ce9310fa7dc785d1a0c4cb8b487bc948 (diff)
downloadmaster-31e0f0ae-8533636d2d106ed19c752239c866fc89bcefffc2.tar.gz
master-31e0f0ae-8533636d2d106ed19c752239c866fc89bcefffc2.tar.bz2
master-31e0f0ae-8533636d2d106ed19c752239c866fc89bcefffc2.zip
uhttpd: cope with variable number of spaces in header lines (#11079)
SVN-Revision: 30806
Diffstat (limited to 'package')
-rw-r--r--package/uhttpd/Makefile4
-rw-r--r--package/uhttpd/src/uhttpd.c9
2 files changed, 8 insertions, 5 deletions
diff --git a/package/uhttpd/Makefile b/package/uhttpd/Makefile
index e0e567af45..5688073add 100644
--- a/package/uhttpd/Makefile
+++ b/package/uhttpd/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2010-2011 Jo-Philipp Wich <xm@subsignal.org>
+# Copyright (C) 2010-2012 Jo-Philipp Wich <xm@subsignal.org>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_RELEASE:=30
+PKG_RELEASE:=31
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
PKG_CONFIG_DEPENDS := \
diff --git a/package/uhttpd/src/uhttpd.c b/package/uhttpd/src/uhttpd.c
index 3563d91d16..9b9608628d 100644
--- a/package/uhttpd/src/uhttpd.c
+++ b/package/uhttpd/src/uhttpd.c
@@ -337,11 +337,14 @@ static struct http_request * uh_http_header_parse(struct client *cl, char *buffe
}
/* have name but no value and found a colon, start of value */
- else if( hdrname && !hdrdata && ((i+2) < buflen) &&
- (buffer[i] == ':') && (buffer[i+1] == ' ')
+ else if( hdrname && !hdrdata &&
+ ((i+1) < buflen) && (buffer[i] == ':')
) {
buffer[i] = 0;
- hdrdata = &buffer[i+2];
+ hdrdata = &buffer[i+1];
+
+ while ((hdrdata + 1) < (buffer + buflen) && *hdrdata == ' ')
+ hdrdata++;
}
/* have no name and found [A-Za-z], start of name */