summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-04-07 21:23:09 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-04-07 21:23:09 +0000
commit843ac4a11abe1b2458512d3a7146d41b339d5eb0 (patch)
treec6aadde205d900e597a7789135eff7846b786309 /package
parent44c1a9e5e52c45ccbfef31312aa3e8822b15995a (diff)
downloadmaster-31e0f0ae-843ac4a11abe1b2458512d3a7146d41b339d5eb0.tar.gz
master-31e0f0ae-843ac4a11abe1b2458512d3a7146d41b339d5eb0.tar.bz2
master-31e0f0ae-843ac4a11abe1b2458512d3a7146d41b339d5eb0.zip
package/grub: play it safe, cross compile everywhere
SVN-Revision: 20739
Diffstat (limited to 'package')
-rw-r--r--package/grub/Makefile10
1 files changed, 0 insertions, 10 deletions
diff --git a/package/grub/Makefile b/package/grub/Makefile
index 94695ec970..338dbcac1d 100644
--- a/package/grub/Makefile
+++ b/package/grub/Makefile
@@ -31,20 +31,10 @@ define Package/grub
URL:=http://www.gnu.org/software/grub/
endef
-ifeq ($(HOST_OS),Linux)
- NATIVEGRUB-i386:=1
- NATIVEGRUB-i686:=1
- NATIVEGRUB:=$(NATIVEGRUB-$(HOST_ARCH))
-endif
-
-ifeq ($(NATIVEGRUB),)
CONFIGURE_FLAGS:= \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME)
-else
-CONFIGURE_FLAGS:=
-endif
ifneq ($(HOST_OS),Darwin)
define Build/Configure