summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-10-04 09:49:49 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-10-04 09:49:49 +0000
commit83246559fdb2afe803ab35eeafbcb5eaeb7e17a3 (patch)
tree8ac64545b3ac27618a3a6587c33925a6d9c93676 /package
parentf05a30206c2c63999df37f38407bddc54ceca1d3 (diff)
downloadmaster-31e0f0ae-83246559fdb2afe803ab35eeafbcb5eaeb7e17a3.tar.gz
master-31e0f0ae-83246559fdb2afe803ab35eeafbcb5eaeb7e17a3.tar.bz2
master-31e0f0ae-83246559fdb2afe803ab35eeafbcb5eaeb7e17a3.zip
uboot-kirkwood: Add support for iomega iconnect wireless
Signed-off-by: Wojciech Dubowik <Wojciech.Dubowik@neratec.com> SVN-Revision: 23218
Diffstat (limited to 'package')
-rw-r--r--package/uboot-kirkwood/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/uboot-kirkwood/Makefile b/package/uboot-kirkwood/Makefile
index f3f9259a73..d0835e7a36 100644
--- a/package/uboot-kirkwood/Makefile
+++ b/package/uboot-kirkwood/Makefile
@@ -34,7 +34,11 @@ define uboot/dockstar
TITLE:=U-boot for the Seagate Dockstar
endef
-UBOOTS:=sheevaplug dockstar
+define uboot/iconnect
+ TITLE:=U-boot for the Iomega iConnect Wireless
+endef
+
+UBOOTS:=sheevaplug dockstar iconnect
define Package/uboot/template
define Package/uboot-kirkwood-$(1)
@@ -73,6 +77,7 @@ endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
+ u-boot.kwb \
CROSS_COMPILE=$(TARGET_CROSS)
endef
@@ -80,6 +85,8 @@ define Package/uboot/install/default
$(INSTALL_DIR) $(BIN_DIR)
$(CP) $(PKG_BUILD_DIR)/u-boot.bin \
$(BIN_DIR)/openwrt-$(BOARD)-$(1)-u-boot.bin
+ $(CP) $(PKG_BUILD_DIR)/u-boot.kwb \
+ $(BIN_DIR)/openwrt-$(BOARD)-$(1)-u-boot.kwb
endef
define Package/uboot/install/template