summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorClaudio Mignanti <c.mignanti@gmail.com>2010-07-12 13:20:01 +0000
committerClaudio Mignanti <c.mignanti@gmail.com>2010-07-12 13:20:01 +0000
commit828919b2ba61384a9a002c28b9224e9dd608b6c8 (patch)
treef5ab13af7af95e19e566b0521e77f236bc1c7a87 /package
parent86f3d57a005a6cba0997c5746b72371c9d17aaa9 (diff)
downloadmaster-31e0f0ae-828919b2ba61384a9a002c28b9224e9dd608b6c8.tar.gz
master-31e0f0ae-828919b2ba61384a9a002c28b9224e9dd608b6c8.tar.bz2
master-31e0f0ae-828919b2ba61384a9a002c28b9224e9dd608b6c8.zip
Add package for gpio-pwm
SVN-Revision: 22143
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 071645984b..9b8259b3df 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -661,3 +661,19 @@ define KernelPackage/wdt-scx200/description
endef
$(eval $(call KernelPackage,wdt-scx200))
+
+
+define KernelPackage/pwm-gpio
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=PWM over GPIO
+ KCONFIG:=CONFIG_GENERIC_PWM \
+ CONFIG_GPIO_PWM
+ FILES:=$(LINUX_DIR)/drivers/pwm/gpio-pwm.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,51,gpio-pwm)
+endef
+
+define KernelPackage/pwm-gpio/description
+ Kernel module to models a single-channel PWM device using a timer and a GPIO pin
+endef
+
+$(eval $(call KernelPackage,pwm-gpio))