summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-08-04 21:47:29 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-08-04 21:47:29 +0000
commit815b18051b29d4c65a4dd216e1a0fb21eed93faf (patch)
tree6d479f5c33bf69b56d4205cf152b97c3f45dc1ab /package
parente8fe990549525eef4174c43fdb8c994fac7ef1ba (diff)
downloadmaster-31e0f0ae-815b18051b29d4c65a4dd216e1a0fb21eed93faf.tar.gz
master-31e0f0ae-815b18051b29d4c65a4dd216e1a0fb21eed93faf.tar.bz2
master-31e0f0ae-815b18051b29d4c65a4dd216e1a0fb21eed93faf.zip
pppd: only remove own default route on shutdown (#7694)
SVN-Revision: 22495
Diffstat (limited to 'package')
-rw-r--r--package/ppp/Makefile2
-rw-r--r--package/ppp/patches/320-custom_iface_names.patch4
-rw-r--r--package/ppp/patches/330-retain_foreign_default_routes.patch10
3 files changed, 12 insertions, 4 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index e0724fffa7..168895544e 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.4
-PKG_RELEASE:=8
+PKG_RELEASE:=9
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
diff --git a/package/ppp/patches/320-custom_iface_names.patch b/package/ppp/patches/320-custom_iface_names.patch
index 16d90c4d7a..ff9ef86dd3 100644
--- a/package/ppp/patches/320-custom_iface_names.patch
+++ b/package/ppp/patches/320-custom_iface_names.patch
@@ -78,7 +78,7 @@
if (ppp_dev_fd >= 0) {
dbglog("in make_ppp_unit, already had /dev/ppp open?");
-@@ -645,6 +650,32 @@ static int make_ppp_unit()
+@@ -645,6 +650,30 @@ static int make_ppp_unit()
}
if (x < 0)
error("Couldn't create new ppp unit: %m");
@@ -103,8 +103,6 @@
+ error("Couldn't rename %s to %s", ifr.ifr_name, ifr.ifr_newname);
+ close(ppp_dev_fd);
+ ppp_dev_fd = -1;
-+ } else {
-+ info("Renamed %s to %s", ifr.ifr_name, ifr.ifr_newname);
+ }
+ }
+
diff --git a/package/ppp/patches/330-retain_foreign_default_routes.patch b/package/ppp/patches/330-retain_foreign_default_routes.patch
new file mode 100644
index 0000000000..d60ccae50c
--- /dev/null
+++ b/package/ppp/patches/330-retain_foreign_default_routes.patch
@@ -0,0 +1,10 @@
+--- a/pppd/sys-linux.c
++++ b/pppd/sys-linux.c
+@@ -1717,6 +1717,7 @@ int cifdefaultroute (int unit, u_int32_t
+ SIN_ADDR(rt.rt_genmask) = 0L;
+ }
+
++ rt.rt_dev = ifname;
+ rt.rt_flags = RTF_UP;
+ if (ioctl(sock_fd, SIOCDELRT, &rt) < 0 && errno != ESRCH) {
+ if (still_ppp()) {