summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-19 10:06:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-19 10:06:18 +0000
commit808a605453c128ba959934a6df0bf12bf7652079 (patch)
tree7cee3e5ef0a9cc7600d0e7e31c6faaf9a9c17cf0 /package
parent10557694bbb8d718381f56414d7d618b18f5257b (diff)
downloadmaster-31e0f0ae-808a605453c128ba959934a6df0bf12bf7652079.tar.gz
master-31e0f0ae-808a605453c128ba959934a6df0bf12bf7652079.tar.bz2
master-31e0f0ae-808a605453c128ba959934a6df0bf12bf7652079.zip
uhttpd: add option for mbedtls
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 48343
Diffstat (limited to 'package')
-rw-r--r--package/network/services/uhttpd/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 2b05abf943..da5572b5fe 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -54,6 +54,7 @@ define Package/uhttpd-mod-tls
TITLE+= (TLS plugin)
DEPENDS:=uhttpd \
+PACKAGE_uhttpd-mod-tls_polarssl:libustream-polarssl \
+ +PACKAGE_uhttpd-mod-tls_mbedtls:libustream-mbedtls \
+PACKAGE_uhttpd-mod-tls_cyassl:libustream-cyassl \
+PACKAGE_uhttpd-mod-tls_openssl:libustream-openssl
endef
@@ -68,6 +69,9 @@ define Package/uhttpd-mod-tls/config
prompt "TLS Provider"
default PACKAGE_uhttpd-mod-tls_polarssl
+ config PACKAGE_uhttpd-mod-tls_mbedtls
+ bool "mbedTLS"
+
config PACKAGE_uhttpd-mod-tls_polarssl
bool "PolarSSL"