summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2008-07-30 17:09:01 +0000
committerJohn Crispin <john@openwrt.org>2008-07-30 17:09:01 +0000
commit79aebec9e0b6c1cf84de2b43a9c674b6741e6465 (patch)
treecb4f039e37e50d621316ccd55e8cbde347f1960a /package
parent93ce64320a8db6c5cdff9ab1e4e047f4ebd8def4 (diff)
downloadmaster-31e0f0ae-79aebec9e0b6c1cf84de2b43a9c674b6741e6465.tar.gz
master-31e0f0ae-79aebec9e0b6c1cf84de2b43a9c674b6741e6465.tar.bz2
master-31e0f0ae-79aebec9e0b6c1cf84de2b43a9c674b6741e6465.zip
creates a passwd's shadow file if busybox supports the feature, fixes #2887
SVN-Revision: 12017
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index f4ef55d110..231647e98b 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -147,6 +147,7 @@ define Package/base-files$(TARGET)/install
$(CP) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)/* $(1)/; \
fi \
)
+ $(if $(CONFIG_BUSYBOX_CONFIG_FEATURE_SHADOWPASSWDS),cp $(1)/etc/passwd $(1)/etc/shadow)
$(SED) 's,$$$$R,$(REVISION),g' $(1)/etc/banner
$(SED) 's,$$$$S,$(BOARD),g' -e 's,$$$$A,$(ARCH),g' $(1)/etc/ipkg.conf
mkdir -p $(1)/dev