summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2015-07-04 01:24:37 +0000
committerFlorian Fainelli <florian@openwrt.org>2015-07-04 01:24:37 +0000
commit763058d536a0fe8b50f7479c8626e7f5a4283033 (patch)
tree1049efc428a8d5c194ae37197bc8363b40d2e01a /package
parentd04f2317063995da4c9ca4c413d7dce7a36a3f1c (diff)
downloadmaster-31e0f0ae-763058d536a0fe8b50f7479c8626e7f5a4283033.tar.gz
master-31e0f0ae-763058d536a0fe8b50f7479c8626e7f5a4283033.tar.bz2
master-31e0f0ae-763058d536a0fe8b50f7479c8626e7f5a4283033.zip
kernel: fix OHCI and EHCI modules for AT91
We were not copying the additional files needed to get USB to work on the AT91 platforms, make sure we do this. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 46172
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/usb.mk13
1 files changed, 10 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 446a92aca8..8f6013c3db 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -315,7 +315,10 @@ define KernelPackage/usb-ohci
FILES:= \
$(LINUX_DIR)/drivers/usb/host/ohci-hcd.ko \
$(LINUX_DIR)/drivers/usb/host/ohci-platform.ko
- AUTOLOAD:=$(call AutoLoad,50,ohci-hcd ohci-platform,1)
+ ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ohci-at91.ko),)
+ FILES+=$(LINUX_DIR)/drivers/usb/host/ohci-at91.ko
+ endif
+ AUTOLOAD:=$(call AutoLoad,50,ohci-hcd ohci-platform ohci-at91,1)
$(call AddDepends/usb)
endef
@@ -416,14 +419,18 @@ define KernelPackage/usb2
CONFIG_USB_EHCI_MXC=y \
CONFIG_USB_OCTEON_EHCI=y \
CONFIG_USB_EHCI_HCD_ORION=y \
- CONFIG_USB_EHCI_HCD_PLATFORM=y
+ CONFIG_USB_EHCI_HCD_PLATFORM=y \
+ CONFIG_USB_EHCI_HCD_AT91=y
FILES:= \
$(LINUX_DIR)/drivers/usb/host/ehci-hcd.ko \
$(LINUX_DIR)/drivers/usb/host/ehci-platform.ko
ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-orion.ko),)
FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-orion.ko
endif
- AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion,1)
+ ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko),)
+ FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko
+ endif
+ AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion ehci-atmel,1)
$(call AddDepends/usb)
endef