summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-03-11 08:22:47 +0000
committerJohn Crispin <john@openwrt.org>2011-03-11 08:22:47 +0000
commit762ac8856a4519864e205a42d968bda6ff06aa93 (patch)
treeb864849b1282fa7d5873e15a2db11c795c6bb142 /package
parent5264a14074d51941f1dce1561518886b188d56ad (diff)
downloadmaster-31e0f0ae-762ac8856a4519864e205a42d968bda6ff06aa93.tar.gz
master-31e0f0ae-762ac8856a4519864e205a42d968bda6ff06aa93.tar.bz2
master-31e0f0ae-762ac8856a4519864e205a42d968bda6ff06aa93.zip
* add some compile flags
SVN-Revision: 26025
Diffstat (limited to 'package')
-rw-r--r--package/uboot-lantiq/patches/010-fix-mips-flags.patch6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/uboot-lantiq/patches/010-fix-mips-flags.patch b/package/uboot-lantiq/patches/010-fix-mips-flags.patch
index 4c706a7843..6dd7d8f569 100644
--- a/package/uboot-lantiq/patches/010-fix-mips-flags.patch
+++ b/package/uboot-lantiq/patches/010-fix-mips-flags.patch
@@ -1,6 +1,6 @@
--- a/cpu/mips/config.mk
+++ b/cpu/mips/config.mk
-@@ -23,16 +23,18 @@
+@@ -23,17 +23,19 @@
v=$(shell $(AS) --version | grep 'GNU assembler' | egrep -o '2\.[0-9\.]+' | cut -d. -f2)
MIPSFLAGS:=$(shell \
if [ "$v" -lt "14" ]; then \
@@ -19,5 +19,7 @@
endif
+endif
- MIPSFLAGS += $(ENDIANNESS)
+-MIPSFLAGS += $(ENDIANNESS)
++MIPSFLAGS += $(ENDIANNESS) -fno-schedule-insns -fno-schedule-insns2
+ PLATFORM_CPPFLAGS += $(MIPSFLAGS)