summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-10-31 11:01:28 +0000
committerJohn Crispin <john@openwrt.org>2014-10-31 11:01:28 +0000
commit7589f4baef997052649c075ec56c192c7987e93b (patch)
tree79472098e148250fcd61ba98855ad3f79c8812ae /package
parent1183af0c48998a73595b92381ce0ba39aec19951 (diff)
downloadmaster-31e0f0ae-7589f4baef997052649c075ec56c192c7987e93b.tar.gz
master-31e0f0ae-7589f4baef997052649c075ec56c192c7987e93b.tar.bz2
master-31e0f0ae-7589f4baef997052649c075ec56c192c7987e93b.zip
kernel/modules: add native vxlan package
More recent kernel versions (>= 3.12) support native VXLAN support. The Open VSwitch kernel module tries to build using native VXLAN support if it detects a kernel version >=3.12. The build works fine, but during startup the OVS kernel module does not load. dmesg output is something like this: [ 1201.262842] openvswitch: Unknown symbol vxlan_sock_release [ 1201.262949] openvswitch: Unknown symbol vxlan_xmit_skb [ 1201.263161] openvswitch: Unknown symbol vxlan_sock_add Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com> SVN-Revision: 43126
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netsupport.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index fc85e22f41..376b588982 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -144,6 +144,20 @@ endef
$(eval $(call KernelPackage,8021q))
+define KernelPackage/vxlan
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Native VXLAN Kernel support
+ KCONFIG:=CONFIG_VXLAN
+ FILES:=$(LINUX_DIR)/drivers/net/vxlan.ko
+ AUTOLOAD:=$(call AutoLoad,13,vxlan)
+endef
+
+define KernelPackage/vxlan/description
+ Kernel module for supporting VXLAN in the Kernel.
+ Requires Kernel 3.12 or newer.
+endef
+
+$(eval $(call KernelPackage,vxlan))
define KernelPackage/capi
SUBMENU:=$(NETWORK_SUPPORT_MENU)