summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGeoff Levand <geoffrey.levand@am.sony.com>2009-08-18 23:07:45 +0000
committerGeoff Levand <geoffrey.levand@am.sony.com>2009-08-18 23:07:45 +0000
commit75816814668ff6f42b7d540c0f954030cf482861 (patch)
tree522b2f8eaabc526eacdffbe5c4dea2be01745730 /package
parent8ee102eea1f917809bd0d180d8241511e031d922 (diff)
downloadmaster-31e0f0ae-75816814668ff6f42b7d540c0f954030cf482861.tar.gz
master-31e0f0ae-75816814668ff6f42b7d540c0f954030cf482861.tar.bz2
master-31e0f0ae-75816814668ff6f42b7d540c0f954030cf482861.zip
powerpc: Create a powerpc64 config feature
The config symbol TARGET_ps3 is used in the build files where special handling for the 64 bit PowerPC processors is needed. Introduce a new config feature powerpc64, and replace the use of TARGET_ps3 with powerpc64. Signed-off-by: Geoff Levand <geoffrey.levand@am.sony.com> SVN-Revision: 17306
Diffstat (limited to 'package')
-rw-r--r--package/kexec-tools/Makefile2
-rw-r--r--package/kexec-tools/kexec-config.in2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/kexec-tools/Makefile b/package/kexec-tools/Makefile
index 3f6137d3da..81ae9d37cd 100644
--- a/package/kexec-tools/Makefile
+++ b/package/kexec-tools/Makefile
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/kexec-tools
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=@armeb||@i386||@TARGET_ps3||@mipsel||@mips +zlib
+ DEPENDS:=@armeb||@i386||@powerpc64||@mipsel||@mips +zlib
TITLE:=Kernel boots kernel
URL:=http://kernel.org/pub/linux/kernel/people/horms/kexec-tools/
MENU:=1
diff --git a/package/kexec-tools/kexec-config.in b/package/kexec-tools/kexec-config.in
index 0910ac202e..7aa3f1db2e 100644
--- a/package/kexec-tools/kexec-config.in
+++ b/package/kexec-tools/kexec-config.in
@@ -2,7 +2,7 @@
config KEXEC_TOOLS_TARGET_NAME
string
prompt "Target name for kexec kernel" if PACKAGE_kexec-tools
- default EXTRA_TARGET_ARCH_NAME if TARGET_ps3
+ default EXTRA_TARGET_ARCH_NAME if powerpc64
default ARCH
help
Defines the target type of the kernels that kexec deals