summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-08-20 15:31:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-08-20 15:31:22 +0000
commit72cf6925a46b5ae49a57460d84b0b4803e232968 (patch)
treec799a5adfd2eb6424f50c032921ebd1352a87d5e /package
parent2982f7ef7976842b0b1482e2ed613a852475a569 (diff)
downloadmaster-31e0f0ae-72cf6925a46b5ae49a57460d84b0b4803e232968.tar.gz
master-31e0f0ae-72cf6925a46b5ae49a57460d84b0b4803e232968.tar.bz2
master-31e0f0ae-72cf6925a46b5ae49a57460d84b0b4803e232968.zip
now that each target has its own package directory, remove the base-files package renaming hack
SVN-Revision: 17330
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index fb7debf96c..92257d8011 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -32,9 +32,7 @@ else
LIBGCC_VERSION:=<LIBGCC_VERSION>
endif
-CONFIG_PACKAGE_base-files$(TARGET):=$(CONFIG_PACKAGE_base-files)
-
-define Package/base-files$(TARGET)
+define Package/base-files
SECTION:=base
CATEGORY:=Base system
TITLE:=Base filesystem for OpenWrt
@@ -47,7 +45,7 @@ define Package/base-files$(TARGET)
$(call Config,network.lan.dns,ip,,LAN DNS server)
endef
-define Package/base-files$(TARGET)/conffiles
+define Package/base-files/conffiles
/etc/banner
/etc/hosts
/etc/inittab
@@ -59,7 +57,7 @@ define Package/base-files$(TARGET)/conffiles
$(call $(TARGET)/conffiles)
endef
-define Package/base-files$(TARGET)/description
+define Package/base-files/description
This package contains a base filesystem and system scripts for OpenWrt.
endef
@@ -140,7 +138,7 @@ define Build/Compile
$(call Build/Compile/Default)
endef
-define Package/base-files$(TARGET)/install
+define Package/base-files/install
$(CP) ./files/* $(1)/
if [ -d $(GENERIC_PLATFORM_DIR)/base-files/. ]; then \
$(CP) $(GENERIC_PLATFORM_DIR)/base-files/* $(1)/; \
@@ -277,7 +275,7 @@ ifneq ($(DUMP),1)
-include $(PLATFORM_DIR)/base-files.mk
endif
-$(eval $(call BuildPackage,base-files$(TARGET)))
+$(eval $(call BuildPackage,base-files))
$(eval $(call BuildPackage,libc))
$(eval $(call BuildPackage,libgcc))
$(eval $(call BuildPackage,libssp))