summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>2011-04-07 23:31:56 +0000
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>2011-04-07 23:31:56 +0000
commit6fab8201242878b6ed8c88a5053bc60c34b85866 (patch)
tree9e89eaeb4fe463076c2ee31dd2eb0185eda39c31 /package
parent1340b0b98e15fcaacca640bc7e2aa16b330150da (diff)
downloadmaster-31e0f0ae-6fab8201242878b6ed8c88a5053bc60c34b85866.tar.gz
master-31e0f0ae-6fab8201242878b6ed8c88a5053bc60c34b85866.tar.bz2
master-31e0f0ae-6fab8201242878b6ed8c88a5053bc60c34b85866.zip
kernel/modules: Enable Realtek R8169 not only for x86
This enables support for Realtek 8169 based network cards for other platforms than x86. I have a mini-PCI card on ixp4xxx running here. Maybe for the other cards in netdevices.mk a @DEPENDS change from @TARGET_x86 to @PCI_SUPPORT makes also sense. Signed-off-by: Christoph König <christoph.koenig@ikt.uni-hannover.de> SVN-Revision: 26529
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/netdevices.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/modules/netdevices.mk b/package/kernel/modules/netdevices.mk
index e8036f0e00..762a171773 100644
--- a/package/kernel/modules/netdevices.mk
+++ b/package/kernel/modules/netdevices.mk
@@ -224,7 +224,7 @@ $(eval $(call KernelPackage,8139cp))
define KernelPackage/r8169
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=RealTek RTL-8169 PCI Gigabit Ethernet Adapter kernel support
- DEPENDS:=@TARGET_x86
+ DEPENDS:=@PCI_SUPPORT
KCONFIG:=CONFIG_R8169 \
CONFIG_R8169_NAPI=y \
CONFIG_R8169_VLAN=n