summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-09-04 16:03:26 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-09-04 16:03:26 +0000
commit6edf2c577b22c3030acdeda3f9987846374f0193 (patch)
tree482c281cc080030bfc23b6fa2eab9892a82801fa /package
parent4331584485e35e02614476e34a803f879900610d (diff)
downloadmaster-31e0f0ae-6edf2c577b22c3030acdeda3f9987846374f0193.tar.gz
master-31e0f0ae-6edf2c577b22c3030acdeda3f9987846374f0193.tar.bz2
master-31e0f0ae-6edf2c577b22c3030acdeda3f9987846374f0193.zip
add kmod-usb-serial-ipw module
This patch adds support to compile kmod-usb-serial-ipw module. It is used by USB IPWireless communication devices used for 3G. Signed-off-by: Lukas macura <macura@opf.slu.cz> SVN-Revision: 22891
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/usb.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index 4e441915f1..fe69ed500e 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -318,6 +318,17 @@ endef
$(eval $(call KernelPackage,usb-serial-ftdi))
+define KernelPackage/usb-serial-ipw
+ TITLE:=Support for IPWireless 3G devices
+ KCONFIG:=CONFIG_USB_SERIAL_IPW
+ FILES:=$(LINUX_DIR)/drivers/usb/serial/ipw.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,65,ipw)
+ $(call AddDepends/usb-serial)
+endef
+
+$(eval $(call KernelPackage,usb-serial-ipw))
+
+
define KernelPackage/usb-serial-mct
TITLE:=Support for Magic Control Tech. devices
KCONFIG:=CONFIG_USB_SERIAL_MCT_U232