summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-10-05 17:13:07 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-10-05 17:13:07 +0000
commit6a10b180ce8198e59be5dfc1e93227824fe4b87c (patch)
tree9e706c56eda0334016a57939a2e01578bfd535e4 /package
parent27a1e6cc6a23eea80dedd3ea5886cecd33bc6ae9 (diff)
downloadmaster-31e0f0ae-6a10b180ce8198e59be5dfc1e93227824fe4b87c.tar.gz
master-31e0f0ae-6a10b180ce8198e59be5dfc1e93227824fe4b87c.tar.bz2
master-31e0f0ae-6a10b180ce8198e59be5dfc1e93227824fe4b87c.zip
ppp: mark /etc/ppp/ resources as conffiles
SVN-Revision: 23248
Diffstat (limited to 'package')
-rw-r--r--package/ppp/Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index 4107ef6864..cab220a3e3 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -40,6 +40,16 @@ define Package/ppp/description
This package contains the PPP (Point-to-Point Protocol) daemon.
endef
+define Package/ppp/conffiles
+/etc/ppp/chap-secrets
+/etc/ppp/filter
+/etc/ppp/ip-down
+/etc/ppp/ip-up
+/etc/ppp/ipv6-down
+/etc/ppp/ipv6-up
+/etc/ppp/options
+endef
+
define Package/ppp-mod-pppoa
$(call Package/ppp/Default)
DEPENDS:=ppp +linux-atm +kmod-pppoa
@@ -71,6 +81,14 @@ This package contains a RADIUS (Remote Authentication Dial-In User Service)
plugin for ppp.
endef
+define Package/ppp-mod-radius/conffiles
+/etc/ppp/radius.conf
+/etc/ppp/radius/dictionary
+/etc/ppp/radius/dictionary.asnet
+/etc/ppp/radius/dictionary.microsoft
+/etc/ppp/radius/servers
+endef
+
define Package/chat
$(call Package/ppp/Default)
DEPENDS:=ppp
@@ -143,7 +161,7 @@ define Package/ppp/install
$(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
ln -sf /tmp/resolv.conf.ppp $(1)/etc/ppp/resolv.conf
endef
-
+
define Package/ppp-mod-pppoa/install
$(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/pppd/$(PKG_VERSION)/pppoatm.so \