summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-21 02:02:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-21 02:02:01 +0000
commit69d76bb482633a1f0af1dc635a3286062e0397cf (patch)
treee9b736fcd92c039ec8c8a8f53eb7ee4554266ba1 /package
parent7248b5e0a964892581e83bb52265c51f98db7040 (diff)
downloadmaster-31e0f0ae-69d76bb482633a1f0af1dc635a3286062e0397cf.tar.gz
master-31e0f0ae-69d76bb482633a1f0af1dc635a3286062e0397cf.tar.bz2
master-31e0f0ae-69d76bb482633a1f0af1dc635a3286062e0397cf.zip
make spca5xx depend on video device support in the kernel
SVN-Revision: 6153
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk1
-rw-r--r--package/spca5xx/Makefile2
2 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index d0975e01c7..d644ce5f5a 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -229,6 +229,7 @@ $(eval $(call KernelPackage,softdog))
define KernelPackage/videodev
TITLE=Video4Linux support
DESCRIPTION:=Kernel modules for Video4Linux support
+ DEPENDS:=@VIDEO_SUPPORT
SUBMENU:=$(EMENU)
KCONFIG:=$(CONFIG_VIDEO_DEV)
FILES:=$(MODULES_DIR)/kernel/drivers/media/video/*.$(LINUX_KMOD_SUFFIX)
diff --git a/package/spca5xx/Makefile b/package/spca5xx/Makefile
index 33f4ef0c47..078759bf46 100644
--- a/package/spca5xx/Makefile
+++ b/package/spca5xx/Makefile
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
define KernelPackage/spca5xx
SUBMENU:=Other modules
- DEPENDS:=kmod-usb-core kmod-videodev
+ DEPENDS:=kmod-usb-core kmod-videodev @VIDEO_SUPPORT
TITLE:=Driver for SPCA5xx based USB cameras
URL:=http://mxhaard.free.fr/
VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)