summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-06-10 12:42:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-06-10 12:42:25 +0000
commit69636a944a72e95b683a0488288a9723f7a15b64 (patch)
tree60a12b1b1a391a19934f2c06bceb3b5233ebfa0e /package
parent15f17901f97bb94b7f00a608388aa5e0e6591691 (diff)
downloadmaster-31e0f0ae-69636a944a72e95b683a0488288a9723f7a15b64.tar.gz
master-31e0f0ae-69636a944a72e95b683a0488288a9723f7a15b64.tar.bz2
master-31e0f0ae-69636a944a72e95b683a0488288a9723f7a15b64.zip
uci: update to latest version, adds uci<->blobmsg conversion code from netifd
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 36908
Diffstat (limited to 'package')
-rw-r--r--package/uci/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/uci/Makefile b/package/uci/Makefile
index bdd9ab3880..2dbd0eecd0 100644
--- a/package/uci/Makefile
+++ b/package/uci/Makefile
@@ -7,20 +7,19 @@
include $(TOPDIR)/rules.mk
-UCI_VERSION=2013-05-26
+UCI_VERSION=2013-06-10
UCI_RELEASE=1
PKG_NAME:=uci
PKG_VERSION:=$(UCI_VERSION)$(if $(UCI_RELEASE),.$(UCI_RELEASE))
PKG_RELEASE:=1
-PKG_REV:=9ef6964362f917ba035020d439d05b36abfe5bb9
+PKG_REV:=9d8e1fe4857c1c3e8f1a2e2ae59ef9c4790adb39
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=git://nbd.name/uci.git
PKG_SOURCE_SUBDIR:=uci-$(PKG_VERSION)
PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_SOURCE_PROTO:=git
-PKG_MIRROR_MD5SUM:=05585c577ae39173920d0a44bda9537a
PKG_LICENSE:=LGPLv2.1 GPLv2
PKG_LICENSE_FILES:=
@@ -39,6 +38,7 @@ define Package/libuci
SECTION:=libs
CATEGORY:=Libraries
TITLE:=C library for the Unified Configuration Interface (UCI)
+ DEPENDS:=+libubox
endef
define Package/uci
@@ -81,7 +81,7 @@ endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
- $(CP) $(PKG_BUILD_DIR)/uci{,_config,map}.h $(1)/usr/include
+ $(CP) $(PKG_BUILD_DIR)/uci{,_config,_blob,map}.h $(1)/usr/include
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/libuci.so* $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/libucimap.a $(1)/usr/lib