summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-08-02 13:53:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-08-02 13:53:23 +0000
commit658cfef9bc33752a05c154d58adba25838bbab1e (patch)
treea6c1b38635cd0c5208ea66d11ede53b46a452d28 /package
parent21075a17f77be37c466053f6150e8fcf8f6d52cd (diff)
downloadmaster-31e0f0ae-658cfef9bc33752a05c154d58adba25838bbab1e.tar.gz
master-31e0f0ae-658cfef9bc33752a05c154d58adba25838bbab1e.tar.bz2
master-31e0f0ae-658cfef9bc33752a05c154d58adba25838bbab1e.zip
Add a zyxel prestige profile for the adm5120eb target, build the hcd driver as a module
SVN-Revision: 8317
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/usb.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index 32a1457248..6d2545a310 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -90,6 +90,16 @@ define KernelPackage/usb-ohci/2.6
endef
$(eval $(call KernelPackage,usb-ohci))
+define KernelPackage/usb-adm5120
+ $(call usbdep,@LINUX_2_6_ADM5120||@LINUX_2_6_ADM5120EB)
+ TITLE:=Support for the ADM5120 HCD controller
+ DESCRIPTION:=Kernel support for the ADM5120 HCD USB controller
+ KCONFIG:=CONFIG_USB_ADM5120_HCD
+ FILES:=$(LINUX_DIR)/drivers/usb/host/adm5120-hcd.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,adm5120-hcd)
+endef
+$(eval $(call KernelPackage,usb-adm5120))
+
define KernelPackage/usb2
$(call usbdep,)
TITLE:=Support for USB2 controllers