summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-09-25 10:47:39 +0000
committerNicolas Thill <nico@openwrt.org>2008-09-25 10:47:39 +0000
commit63e039705837a6ab3476c853bbffcb2e4d7f523f (patch)
treeb29fd149361a68e9e55a9eabd8039813ef32029b /package
parent59a058534cb0106c691462de6e1516fb4511c376 (diff)
downloadmaster-31e0f0ae-63e039705837a6ab3476c853bbffcb2e4d7f523f.tar.gz
master-31e0f0ae-63e039705837a6ab3476c853bbffcb2e4d7f523f.tar.bz2
master-31e0f0ae-63e039705837a6ab3476c853bbffcb2e4d7f523f.zip
call autoconf when there's no ./configure script, move it at Build/Prepare stage
SVN-Revision: 12693
Diffstat (limited to 'package')
-rw-r--r--package/bridge-utils/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/package/bridge-utils/Makefile b/package/bridge-utils/Makefile
index c771ab7cb5..e45bcb0f0b 100644
--- a/package/bridge-utils/Makefile
+++ b/package/bridge-utils/Makefile
@@ -42,11 +42,13 @@ endef
CONFIGURE_ARGS += \
--with-linux-headers="$(LINUX_DIR)" \
-define Build/Configure
- (cd $(PKG_BUILD_DIR); \
- [ "$(PKG_VERSION)" = "1.0.6" ] || ln -s configure.in configure.ac; \
- autoconf; \
- ./configure $(CONFIGURE_ARGS) \
+define Build/Prepare
+$(call Build/Prepare/Default)
+ ( cd $(PKG_BUILD_DIR) ; \
+ [ -f ./configure ] || { \
+ ln -sf configure.in configure.ac ; \
+ autoconf ; \
+ } \
)
endef