summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-23 20:01:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-23 20:01:26 +0000
commit6255856c681ac41b9cc3e8ac8256d2fcb7142677 (patch)
tree461d897859493710513345468c5f04038ce885cf /package
parent7e29a768fa1899bab375ca16e3d4f898d9e6723f (diff)
downloadmaster-31e0f0ae-6255856c681ac41b9cc3e8ac8256d2fcb7142677.tar.gz
master-31e0f0ae-6255856c681ac41b9cc3e8ac8256d2fcb7142677.tar.bz2
master-31e0f0ae-6255856c681ac41b9cc3e8ac8256d2fcb7142677.zip
kernel: add a package for bcm-phy-lib.ko, fixes build errors with kmod-phy-broadcom
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48464
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netdevices.mk15
1 files changed, 14 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index ef3cf85ef8..417a6a6114 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -148,11 +148,24 @@ endef
$(eval $(call KernelPackage,gw16083))
+define KernelPackage/phylib-broadcom
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=Broadcom Ethernet PHY library
+ KCONFIG:=CONFIG_BCM_NET_PHYLIB
+ HIDDEN:=1
+ DEPENDS:=+kmod-libphy
+ FILES:=$(LINUX_DIR)/drivers/net/phy/bcm-phy-lib.ko
+ AUTOLOAD:=$(call AutoLoad,17,bcm-phy-lib)
+endef
+
+$(eval $(call KernelPackage,phylib-broadcom))
+
+
define KernelPackage/phy-broadcom
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Broadcom Ethernet PHY driver
KCONFIG:=CONFIG_BROADCOM_PHY
- DEPENDS:=+kmod-libphy
+ DEPENDS:=+kmod-libphy +kmod-phylib-broadcom
FILES:=$(LINUX_DIR)/drivers/net/phy/broadcom.ko
AUTOLOAD:=$(call AutoLoad,18,broadcom)
endef