summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-04 06:10:57 +0000
committerJohn Crispin <john@openwrt.org>2015-02-04 06:10:57 +0000
commit600548e472c5e62adfa337a75c2702b14d253a25 (patch)
tree953c860176592b536ed94639d7b1378915ba94d0 /package
parentcde2225c7c0674fa1b334645cce8ada797cc6a24 (diff)
downloadmaster-31e0f0ae-600548e472c5e62adfa337a75c2702b14d253a25.tar.gz
master-31e0f0ae-600548e472c5e62adfa337a75c2702b14d253a25.tar.bz2
master-31e0f0ae-600548e472c5e62adfa337a75c2702b14d253a25.zip
linux/modules: add support for Asix ax88179 USB-Gigabit Ethernet adapters
requested and tested by forum user OWonPi https://forum.openwrt.org/viewtopic.php?id=55495 Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> SVN-Revision: 44256
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/usb.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 7498bcb014..431c7baa2c 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1027,6 +1027,23 @@ endef
$(eval $(call KernelPackage,usb-net-asix))
+define KernelPackage/usb-net-asix-ax88179
+ TITLE:=Kernel module for USB-to-Gigabit-Ethernet Asix convertors
+ DEPENDS:=+kmod-libphy
+ KCONFIG:=CONFIG_USB_NET_AX88179_178A
+ FILES:=$(LINUX_DIR)/drivers/$(USBNET_DIR)/ax88179_178a.ko
+ AUTOLOAD:=$(call AutoProbe,ax88179_178a)
+ $(call AddDepends/usb-net)
+endef
+
+define KernelPackage/usb-net-asix-ax88179/description
+ Kernel module for USB-to-Ethernet ASIX AX88179 based USB 3.0/2.0
+ to Gigabit Ethernet adapters.
+endef
+
+$(eval $(call KernelPackage,usb-net-asix-ax88179))
+
+
define KernelPackage/usb-net-hso
TITLE:=Kernel module for Option USB High Speed Mobile Devices
KCONFIG:=CONFIG_USB_HSO