summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-09-30 14:48:31 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-09-30 14:48:31 +0000
commit5df80ba3a7fdf6c89b298e800f9dca875f785fec (patch)
tree0b09bc648053b6eb939b4885c8f47dded3102ac9 /package
parente9eb82b33b517f7ea982fc574c910bf84dcc0a18 (diff)
downloadmaster-31e0f0ae-5df80ba3a7fdf6c89b298e800f9dca875f785fec.tar.gz
master-31e0f0ae-5df80ba3a7fdf6c89b298e800f9dca875f785fec.tar.bz2
master-31e0f0ae-5df80ba3a7fdf6c89b298e800f9dca875f785fec.zip
package/grub: fix build issues under 64bit FreeBSD
SVN-Revision: 23162
Diffstat (limited to 'package')
-rw-r--r--package/grub/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/package/grub/Makefile b/package/grub/Makefile
index f3dd171141..ee527be13f 100644
--- a/package/grub/Makefile
+++ b/package/grub/Makefile
@@ -37,10 +37,6 @@ MY_CONFIGURE_ARGS += \
--disable-hercules \
--without-curses \
-ifeq ($(HOST_OS),FreeBSD)
- MY_CONFIGURE_ARGS += --build=$(GNU_HOST_NAME) --host=$(GNU_TARGET_NAME) --target=$(GNU_TARGET_NAME)
-endif
-
MY_CONFIGURE_VARS += \
grub_cv_prog_objcopy_absolute=yes \
@@ -53,6 +49,14 @@ ifeq ($(HOST_OS),Darwin)
HOST_CFLAGS += $(call host-cc-option,-fnested-functions)
endif
+ifeq ($(HOST_OS),FreeBSD)
+ ifeq ($(HOST_ARCH),amd64)
+ HOST_CFLAGS += $(call host-cc-option,-m32)
+ HOST_CFLAGS += $(call host-cc-option,-B/usr/lib32)
+ HOST_CFLAGS += $(call host-cc-option,-L/usr/lib32)
+ endif
+endif
+
HOST_CFLAGS += $(call host-cc-option,-fno-stack-protector)
HOST_CFLAGS += $(call host-cc-option,-U_FORTIFY_SOURCE)