summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-24 10:07:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-24 10:07:40 +0000
commit5d9eeab64aadb376a8c07d8faad44b25ac9ce7f5 (patch)
tree10a8d0970c794b914cbf01939dec556f269eb980 /package
parent793a4515845027a38eb32b7c3297ae8266b8c761 (diff)
downloadmaster-31e0f0ae-5d9eeab64aadb376a8c07d8faad44b25ac9ce7f5.tar.gz
master-31e0f0ae-5d9eeab64aadb376a8c07d8faad44b25ac9ce7f5.tar.bz2
master-31e0f0ae-5d9eeab64aadb376a8c07d8faad44b25ac9ce7f5.zip
build: remove obsolete references to cris and avr32
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44965
Diffstat (limited to 'package')
-rw-r--r--package/devel/gdb/Makefile2
-rw-r--r--package/kernel/linux/modules/fs.mk2
-rw-r--r--package/kernel/mac80211/Makefile2
-rw-r--r--package/libs/uclibc++/Makefile1
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/utils/iw/Makefile2
6 files changed, 5 insertions, 6 deletions
diff --git a/package/devel/gdb/Makefile b/package/devel/gdb/Makefile
index c47735a8c0..1611efe564 100644
--- a/package/devel/gdb/Makefile
+++ b/package/devel/gdb/Makefile
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/gdb/Default
SECTION:=devel
CATEGORY:=Development
- DEPENDS:=@!(avr32||cris) +!USE_MUSL:libthread-db +PACKAGE_zlib:zlib
+ DEPENDS:=+!USE_MUSL:libthread-db +PACKAGE_zlib:zlib
URL:=http://www.gnu.org/software/gdb/
endef
diff --git a/package/kernel/linux/modules/fs.mk b/package/kernel/linux/modules/fs.mk
index dd44eb97f9..64182e680d 100644
--- a/package/kernel/linux/modules/fs.mk
+++ b/package/kernel/linux/modules/fs.mk
@@ -437,7 +437,7 @@ define KernelPackage/fs-xfs
SUBMENU:=$(FS_MENU)
TITLE:=XFS filesystem support
KCONFIG:=CONFIG_XFS_FS
- DEPENDS:= +kmod-fs-exportfs +kmod-lib-crc32c @!avr32
+ DEPENDS:= +kmod-fs-exportfs +kmod-lib-crc32c
FILES:=$(LINUX_DIR)/fs/xfs/xfs.ko
AUTOLOAD:=$(call AutoLoad,30,xfs,1)
endef
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 585c2258e7..11c8bcfa1a 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -60,7 +60,7 @@ define KernelPackage/mac80211/Default
SUBMENU:=$(WMENU)
URL:=https://wireless.wiki.kernel.org/
MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
- DEPENDS:=@(!TARGET_avr32||BROKEN) @!TARGET_uml
+ DEPENDS:=@!TARGET_uml
endef
define KernelPackage/cfg80211
diff --git a/package/libs/uclibc++/Makefile b/package/libs/uclibc++/Makefile
index ade3c62e0f..1196926e8c 100644
--- a/package/libs/uclibc++/Makefile
+++ b/package/libs/uclibc++/Makefile
@@ -42,7 +42,6 @@ UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
-e 's/sh[234].*/sh/' \
-e 's/mips.*/mips/' \
-e 's/mipsel.*/mips/' \
- -e 's/cris.*/cris/' \
)
TARGET_CFLAGS += $(FPIC)
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index eeba02802a..592c06c03d 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -94,7 +94,7 @@ ifdef CONFIG_USE_GLIBC
TARGET_LDFLAGS_C += -lrt
endif
-DRV_DEPENDS:=+PACKAGE_kmod-cfg80211:libnl-tiny @(!TARGET_avr32||BROKEN)
+DRV_DEPENDS:=+PACKAGE_kmod-cfg80211:libnl-tiny
define Package/hostapd/Default
SECTION:=net
diff --git a/package/network/utils/iw/Makefile b/package/network/utils/iw/Makefile
index e6054950ca..05ecd8adad 100644
--- a/package/network/utils/iw/Makefile
+++ b/package/network/utils/iw/Makefile
@@ -25,7 +25,7 @@ define Package/iw
CATEGORY:=Network
TITLE:=cfg80211 interface configuration utility
URL:=http://wireless.kernel.org/en/users/Documentation/iw
- DEPENDS:= +libnl-tiny @(!TARGET_avr32||BROKEN)
+ DEPENDS:= +libnl-tiny
endef
define Build/Configure