summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-06-14 18:08:25 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-06-14 18:08:25 +0000
commit55baa6e4675ea9bde883884aa095673b9026d2b8 (patch)
treeb20b47e14eac9fc27127d31ff54bcb7f513155ae /package
parentff17ac5ec3a0a27a7a4e183788efa37d1090cdef (diff)
downloadmaster-31e0f0ae-55baa6e4675ea9bde883884aa095673b9026d2b8.tar.gz
master-31e0f0ae-55baa6e4675ea9bde883884aa095673b9026d2b8.tar.bz2
master-31e0f0ae-55baa6e4675ea9bde883884aa095673b9026d2b8.zip
Move wget2nand to the base-files for adm5120 also fix default permission (#1812)
SVN-Revision: 7633
Diffstat (limited to 'package')
-rw-r--r--package/wget2nand/Makefile37
-rwxr-xr-xpackage/wget2nand/src/wget2nand71
2 files changed, 0 insertions, 108 deletions
diff --git a/package/wget2nand/Makefile b/package/wget2nand/Makefile
deleted file mode 100644
index e029a502e9..0000000000
--- a/package/wget2nand/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-#
-# Copyright (C) 2007 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id: $
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=wget2nand
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/wget2nand
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=RouterOS to OpenWrt install script
- DEPENDS:=@LINUX_2_6_ADM5120
- DESCRIPTION:=\
- A tool to switch from RouterBoard RouterOS to OpenWrt
- URL:=https://dev.openwrt.org/browser/trunk/package/wget2nand/src/wget2nand
- VERSION:=1
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
-endef
-
-define Package/wget2nand/install
- $(INSTALL_DIR) $(1)/sbin
- $(INSTALL_BIN) ./src/$(PKG_NAME) $(1)/sbin/
-endef
-
-$(eval $(call BuildPackage,wget2nand))
diff --git a/package/wget2nand/src/wget2nand b/package/wget2nand/src/wget2nand
deleted file mode 100755
index 9588396fdf..0000000000
--- a/package/wget2nand/src/wget2nand
+++ /dev/null
@@ -1,71 +0,0 @@
-#!/bin/sh
-# wget2nand
-# This script can be used to download a TGZ file from your build system which
-# contains the files to be installed on the NAND flash on your RB1xx card.
-# The one parameter is the URL of the TGZ file to be downloaded.
-# Licence GPL V2
-# Author david.goodenough@linkchoose.co.uk
-# Based on cf2nand from RB532 support
-. /etc/functions.sh
-
-[ -d /tmp/wget2nand ] && {
- echo "/tmp/wget2nand already exists"
- exit 1
-}
-
-# first get an address for br-lan using udhcpc
-killall udhcpc
-/sbin/udhcpc -i br-lan
-
-# need to find the wget server from the command line
-url=$1
-[ -z "$url" ] && {
- echo "No URL specified for image TGZ"
- echo "Usage : $0 URL"
- exit 1
-}
-
-boot="$(find_mtd_part 'RouterBoard NAND Boot')"
-main="$(find_mtd_part 'rootfs')"
-[ -z "$boot" -o -z "$main" ] && {
- echo "Cannot find NAND Flash partitions"
- exit 1
-}
-
-echo "Erasing filesystem."
-mtd erase Boot 2>/dev/null >/dev/null
-mtd erase Main 2>/dev/null >/dev/null
-
-echo "Mounting $main as new root and $boot as boot partition"
-
-mkdir /tmp/wget2nand/
-mkdir /tmp/wget2nand-boot
-mount -t yaffs2 "$main" /tmp/wget2nand/
-mount -t yaffs2 "$boot" /tmp/wget2nand-boot
-
-echo "Copying filesystem..."
-( wget -O - $url/openwrt-adm5120-2.6-rootfs.tgz) | ( cd /tmp/wget2nand/; tar xvz )
-wget -O /tmp/wget2nand-boot/kernel $url/openwrt-adm5120-2.6-vmlinux.elf
-
-# update the command line on the kernel to boot from the right place
-[ ! -e /sbin/patch-cmdline ] && {
- echo "Cannot find patch-cmdline"
- exit 1
-}
-
-echo "Patching the kernel command line"
-/sbin/patch-cmdline /tmp/wget2nand-boot/kernel "root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit "
-chmod +x /tmp/wget2nand-boot/kernel
-
-# make sure everything is written before we unmount the partitions
-sync
-ls /tmp/wget2nand-boot/
-ls /tmp/wget2nand/
-# unmount the partitions and remove the directories into which they were mounted
-umount /tmp/wget2nand-boot
-umount /tmp/wget2nand
-rmdir /tmp/wget2nand-boot
-rmdir /tmp/wget2nand
-
-# all done
-echo "Image written, you can now reboot. Remember to change the boot source to Boot from Nand"