summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-12-19 09:41:28 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-12-19 09:41:28 +0000
commit50983767b37ee20c8bb62553d72abfee4bb800dd (patch)
treee68b6f1f97243afa5db6b876eba1267e4360dc24 /package
parent5f82aa4d15a885c5b211a565adf6a95ba66c374e (diff)
downloadmaster-31e0f0ae-50983767b37ee20c8bb62553d72abfee4bb800dd.tar.gz
master-31e0f0ae-50983767b37ee20c8bb62553d72abfee4bb800dd.tar.bz2
master-31e0f0ae-50983767b37ee20c8bb62553d72abfee4bb800dd.zip
block-mount: add a delay between sto pand start in fstab init restart action, fixes a lock race condition observed in VirtualBox
SVN-Revision: 34784
Diffstat (limited to 'package')
-rw-r--r--package/block-mount/Makefile2
-rw-r--r--package/block-mount/files/fstab.init6
2 files changed, 6 insertions, 2 deletions
diff --git a/package/block-mount/Makefile b/package/block-mount/Makefile
index 799539e4bd..06deb9401d 100644
--- a/package/block-mount/Makefile
+++ b/package/block-mount/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=block-mount
PKG_VERSION:=0.2.0
-PKG_RELEASE:=9
+PKG_RELEASE:=10
include $(INCLUDE_DIR)/package.mk
diff --git a/package/block-mount/files/fstab.init b/package/block-mount/files/fstab.init
index f54051ebb7..4f1f6fb7a0 100644
--- a/package/block-mount/files/fstab.init
+++ b/package/block-mount/files/fstab.init
@@ -85,4 +85,8 @@ stop() {
swapoff -a
}
-
+restart() {
+ stop
+ sleep 1
+ start
+}